Android annotations disappear

When I make a text annotation in the android client, it often disappears the next time I open the .pdf.

I’ve tried a few experiments to see what conditions cause this, but have not been able to find anything consistent yet
(tried: black-on-white vs white-on-black view mode,
close viewer and move back to main menu before exiting,
on wifi vs not)

This is using the Paperpile client from 13-jan-21 as well as previous versions from last year, on Android9 (Samsung s5 tablet).

1 Like

I’ve just opened up the latest version of Paperpile for Android (updated 28-Feb-2021) to discover that the annotations I made on the last PDF I read a few days ago are, once again, missing. This seems to happen frequently. I’m using a Samsung Tab 5SE.

I’ve down a bit of troubleshooting and tried some of the options @paperbrain mentions, but I haven’t been able to pin down a consistent cause. So, I’m simply flagging that I also continue to experience this issue.

1 Like

I wonder if it would be possible to add an option to simply open the pdf in a different app such as Xodo in order to do annotations. The paperpile app is good for reading, but I really want to be able to annotate, it’s an important part of a research workflow I believe.

In fact i tried this, located (with a bit of difficulty) the pdf on disk (it has a hashed not-recognizable name),
opened in Xodo, annotated. The paperpile android app did not see the changes, maybe because it was not looking for unexpected changes from another program. But could it?

Thanks for the feedback, @paperbrain and @joel. Strange - we’ve had reports of misaligned highlights and the like, but none of annotations not being saved. Does it happen in many different documents? I’ve let the team know; any further details would be helpful.

I haven’t noticed a consistent pattern yet (e.g., if the changes aren’t saved in documents where the highlighting is misaligned), but it happens about one out of every three documents I try to annotate. It’s enough to be disruptive.

Like @paperbrain, I’d like to see an easier way to open pdfs in other apps like Xodo for reading/annotation, and then make sure that these annotations are synched back to Paperpile.

This happens to me too and is honestly quite annoying. I had read quite a few pages on my tablet (Samsung Tab S7) and I’ll have to start again now…
It had also happened before to me, I tought it was because the tablet had gone in standby with the pdf open, but with this last document I had been super careful about closing the app.

Also, I strongly support having the opportunity to use a different editor for annotation and then sync them back.

1 Like

I tried the new March 16 not-beta release, hoping this problem would be fixed.
It might be better, but there is still something weird.

Right now I have this repeating behaviour.

  1. highlighted some text
  2. switch to the tablet “desktop”, the center button on the Samsung tablet.
  3. re-open Paperpile
  4. re-open the paper: highlights are missing
  5. go back to the “all papers” list
  6. re-open the paper, highlights are visible
  7. go back to step 2

I have done this 5-6 times in a row, it seems reliable.

Please fix this or allow us to use a different viewer for annotation.
I really like Paperpile and want to use it!

@paperbrain, the latest release of the app did indeed include significant backend fixes for highlighting/annotating issues like this one; I trust the experience has improved since then? I’ve notified the team about this last behavior you report, will let you know of any updates on the matter.

How about for @Ludovica_Pannitto and @joel, have you continued experiencing missing highlights/annotations? Please let us know.

I haven’t experienced my reported issue so far following the latest update, which is promising! I will provide more information if it returns – but so far, so good.

Thank you!

1 Like

The repeating disappear-reappear behaviour I mentioned in my last message above is using the March16 update v1.2.3, which is the newest version as far as I know.

I have tried out the Ipad version of paperpile and do not find any issue with annotations disappearing in that version.

However for a small particular reason I prefer to use the android (basically, using Ios would mean I would need to cary around two different tablets)

I did some more testing, this time watching the files in Google Drive also.

[ The description of the test refers to the android “back” (looks like <) button and “home” navigation buttons (looks like a rounded square).
After annotating, the back button returns from the pdf to the paperpile entry for that paper (the one with biblio info for that paper), whereas the “home” button goes to the main android “desktop” screen. ]

It seems like one fairly reliable way to cause the missing annotations is to click the android “home” button after creating an annotation (rather than clicking the back button). Then on the desktop, after clicking paperpile and re-opening the pdf, all annotations are missing, both previous ones and the most recently made one.

However, on Google drive what I see is that all the previously made annotations do exist, and only the most recent one (the one followed by the home-button click) is missing. So the problem is both that it is not saving annotations sometimes, but also in some other cases it does not display annotations that exist on drive.

After exiting and reentering Paperpile some random number of times the previous annotations reappear, but the most recent one (which was followed by the ‘home’ click) is permanently gone.

I tested the android app on a pixel slate chromebook (chromebooks can run android apps), and had no problem, was not able to produce the disappearing annotations.

They problem is somewhat random so this is not a definitive test, but it makes me wonder: is the problem specific to samsung tablets? All the people who have mentioned a tablet type (including a comment in the play store) have said Samsung.

Has anyone who uses a not-samsung android tablet had the disappearing annotations problem?