[Bug] Comments made in MetaPDF cannot be seen in Mac Preview

It appears that it is not possible to see text of a comment made in MetaPDF in Mac Preview.

In comparison, when I highlight the text and make a text comment in Adobe Acrobat, there is a little stickie next to highlight that I can click and see the text.

Any plans to fix this?

We did not realize that. “Standalone” sticky notes are shown correctly but comments associated with a text highlight are not shown. They are shown correctly on Acrobat which we use as our gold standard. We need to figure out why they are not shown in Preview.

In any case, one reason why we put so much effort in our own PDF annotator was to be compatible with other viewers. So yes, it’s definitely planned to fix this.

Great, thanks for confirming! I changed the title to indicate this is a Bug.

Ran into this again. Any hints when/if this will be fixed?

I am forced to annotate using other tools, since I am unable to meaningfully share the annotations created using MetaPDF with my colleagues who are not using MetaPDF.

Hi Andrey

We have a fix for this now and it should be included in our next update of our pdf viewer.


How do I know whether the PDF viewer I have was updated or not? How do I get to the version of the viewer running?

Check the changelog: https://paperpile.com/changelog

From the changelog, I see the viewer was updated on Sept 19, but I still don’t see the comments in Preview. Is it supposed to be fixed?

No, this update was only a hot fix for a Chrome bug in 53 and did not contain the other improvements we have made since the last update.

Any updates on this? You guys said you had a fix for this a year ago…

Fixed in the new annotator introduced here: http://forum.paperpile.com/t/new-pdf-annotator-public-beta/2983

I have been faced the same issue but the error code I faced was apple error 4013 which is on my Mac and I tried to resolve this issue and did it. I search on the internet for the solution and I found that but I was afraid to apply but after so much research I found that it is quite safe so I applied. Just ha[py to see that my problem is solved.