Google Doc Bug: Every other character in a sentence gets a hyperlink to a set of references

Thanks for the screenshots. That seems to be the first photographed case in the wild of what has been reported the only recently by @tkurth (I’ve moved it here).

The main question is how does this strange text with all the different links in every character comes into place?

@tkurth mentioned using “Suggest mode” @Alison_Kozol have you also used “Suggest mode” in your document?

It could be a strange merging artifact of edits on the same regions by multiple persons.

The citation formatting seems to work as expected because the “explosion” is what Paperpile does with citation links, it makes full citations out of them.

If this is a common artifact we may need to think about ways to recognize and fix them at the formatting step, but that’s not trivial.

Hi Stefan -

Thank you for your quick response :smile:

To answer your questions:

@Alison_Kozol have you also used “Suggest mode” in your document?
–> Yes

It could be a strange merging artifact of edits on the same regions by
multiple persons.
–> We do have 3 people editing the text

If this is a common artifact we may need to think about ways to
recognize and fix them at the formatting step, but that’s not trivial.

–> This has happened twice so far. I will report back when I see it
again and the circumstances

This issue has been reported again on Twitter today. It seems to occur when “suggestion mode” is used. Somehow it produces text that is intermingled with a Paperpile citation link. Paperpile does not know that these citation links are not correct and formats every citation link resulting in many repeated citations.

We’ve tried every way to reproduce but we could not make Google Docs produce such a broken citation/text combination. As it stands, it’s likely to be a Google Docs issue as neither Paperpile adds text like that nor does the user. So it seems to be a merging issue of edits.

All we can say, it’s extremely rare as we have only been reported 3 incidents so far. Any ideas how to make Google Docs produce such links are welcome.

To fix it, remove the short text segment that contains all the repeated links and re-format.

I’m still having this problem, and it seems to crop up once or twice virtually with virtually every doc I’ve worked with together with PaperPile. It is definitely a hassle. I can spend some time to try and reproduce the issue if it’s still not resolved.

If you can tell us a step-by-step way to reproduce we would be very interested. We tried every time it comes up without success…

I have had exactly the same problem. It usually appears when I am working in the suggesting mode and I click on the “Update Citations and Bibliography.” It then messes up a few sentences in one paragraph where a citation is added after each and every letter. I took a screen shot but as a newbie I am not sure how to post it here.

Michel

Quick update as to how I managed to solve it. The glitch was affecting two sentences so I “undid” the Update citations and bibliography and then retyped the two sentences and deleted the old. I then hit the Update button and the glitch appeared in the new sentence. I then retyped the sentence that was now causing the problem and hit update. This time, I only had one citation that appeared out of place. I deleted that and hit Update. Now, it seems as if everything is working as it should (fingers crossed).

I just managed to reproduce the issue:

Here’s the original text pre-formatting:

If you contact me privately via e-mail, I can send you a link to the doc to reproduce the issue (i.e., go back in revision history, then reformat, happens every time).

Moreover, I have done some testing, and if I copy to a fresh Google Doc, the bug appears again. If I retype the text and insert the citation fresh, it does not appear. It appears to be some bug in the encoding, because even though it’s just one reference, it shows two references. Can’t seem to make it happen again with a fresh citation, though.

Thanks. I’ve sent you a message how you can share the document with me. We might finally get a chance to fix this…

Sorry, I don’t think I got the message. Should it come through the PaperPile forum?

I thought I sent it via email but it may have been sent as an in App message. Just open Paperpile and the message will appear in the bottom right.

Here is another example of this bug. When you click format citations then the last part of the sentence gets garbled: https://docs.google.com/document/d/1Sp-GxeJb6DR2hgXiUbRLj90Bfu96jtq685NMw4NJ7mU/edit?usp=sharing

Thanks, I can’t edit the document so I can’t see the URLs in it. But I would guess the bug is already there in form of multiple Paperpile citation URLs for the letters in the last part of the sentence.

Unfortunately, that’s just the symptom of the bug and we would need to know how does that pattern arise? Any ideas?

So far we think it occurs only when multiple authors edit a document and “suggest” mode is used. Can you confirm that?

I now saw the error the first time myself. I was editing the file myself and did not use suggest mode. So I guess this hypothesis is wrong.

I think it has to do when the document is edited while a citation formatting progress is running. There is no technical way to lock a document so we can’t prevent that.

In principle it should not be necessary because the collaborative model should never get into an inconsistent state. It should not matter if a human and a script like Paperpile edit the document at the same time.

We’ll investigate further.

Just to confirm, the issue is still there. I’ve seen it 4-5 times in the latest document that I have been writing. The only workaround that I have is to download a Word copy of the document before every time I run “Format citations” so that I can manually restore the text when it gets deleted.

What I’ve observed is that sometimes when I insert a citation and add text immediately after than after that then text becomes part of the same hyperlink with the reference. When I subsequently reformat the references than the text gets deleted.

EDIT: Finally managed to reproduce it!

Step 1: Open a new Google Docs file.
Step 2: Add a single Paperpile reference.
Step 3: Change the citation style to Science.
Step 4: Format references. The reference should now appear as (1).
Step 5: Turn on “Suggesting” (track changes).
Step 6: Start writing anything immediately after the reference (no space). For example, write (1)test.
Step 7: Accept changes.
Step 8: Reformat references and notice how the ‘test’ text disappears.

Best wishes,
Kaur

Old comment:

Have seen it three times now today (using Science reference formatting style), and its becoming so annoying that I am considering to stop using Paperpile. It seems to happen when I use track changes to change text somewhere around a reference, accept changes and then reformat references. Here should be a reproducible example:
https://docs.google.com/document/d/1AOrfprwTWTa7xla18B8eOVOPwX2RCRDclDH9WFThGPc/edit?usp=sharing

Notice that when you click on the ‘and’ word then Paperpile thinks that its a part of the reference although it clearly should not be.

Kaur

Thanks for the document. The problem is that I can only see the end result. I’ve worked with a couple of these examples already without any results.

Can you give me a step by step guide how I can produce such a document starting from an empty Google document? It seems you have some “experience” with this bug now that you are closest to reproduce it.

In any case, sorry for all the trouble. We’re fixing bugs with every release but some are exceptionally tough.

Your are very quick! I just edited the previous comment, but you managed to reply first. Can you see if you are able to reproduce it with the 8 steps that I outlined?

Best,
Kaur

Thanks. I finally can now reproduce. :grinning:

Unfortunately this is clearly a Google Docs bug. This has nothing to do with Paperpile.

I can do this with a normal URL. When I add a text that is a URL like “Link” and then write “Link123456” in suggestion mode, every other number will be a URL. This is clearly not the desired behaviour. Instead none of them should be a URL. Here is a video:

We have reported the bug in the Docs help forum and also sent them a “feedback” message through Google Docs. https://productforums.google.com/forum/#!topic/docs/x-G2G9HPk4s;context-place=forum/docs

Unlike in this forum here, it’s impossible to communicate directly with Google Docs developers so the outcome is unclear.