Inconsistent ability to attach PDFs to existing references via chrome add-on


#1

Hi,
I have loved using Paperpile over the last few months but I can’t figure out what makes this feature work or not. I have a bunch of references already in my library but it can’t auto-download all the PDFs. So I go find them and the add-on says the reference is already in my library. Sometimes it includes the option to attach the PDF to the reference I was just looking at and sometimes it doesn’t so I have to go through a few extra steps. It doesn’t seem to have to do with looking at the actual PDF or the page with the link to the PDF. It doesn’t seem to have to do with selecting the reference in paperpile first. Please let me know what I’m missing or if this is something you are working on. Thanks!

As a side-note: any chance of being able to sign into my institution’s library through paperpile so it has access to more pdfs?


#2

If you have selected a paper in Papperpile and view a PDF you should always see a button “Attach to xy” in the “P” popup.

Alternatively you can right click a link to a PDF and use the Chrome context menu “Attach to xy”.

If that does not work consistently there must be something going on which we need to look into. Can you describe a situation when you have selected an item in Paperpile and opened a PDF where you don’t see the “Attach to xy” button?

Feel free to contact support using the in-app messenger. We also can add you to the library proxy beta test.


#4

I use this feature fairly often and I’d give it no better than a 50% chance of working in the way you describe with the “attach to xy” option appearing. Also, I have never seen that option pop up when I right-click the PDF. I have screen shots so you can see that the options you describe aren’t popping up for me. I could only attach one, however, to this post. I’m hopeful that I just have something set incorrectly since no one else seems to have brought this up before and you thought it was working so consistently.

Thanks


#5

Thanks for the screenshot. That explains a lot. Paperpile only shows the “Attach to xy” button if the tab is actually displaying a PDF. The page you are looking at is a normal website which shows an embedded PDF and/or an internal PDF viewer.

The solution would be to open the PDF in a separate tab if that’s an option on this page.

In any case, @andreas and I will discuss how to solve that for this particular page. Thanks.


#6

I have had this problem (no button to ‘attach to xy’) a lot recently when the tab is displaying a PDF. I think this feature used to work reliably for me, but just today I have had two cases of being unable to ‘attach to xy’ for quite a long time, and I tried all sorts of other ways to attach the paper but was unable to do so. Browsing for a PDF to manually upload the attachment is not working for me at the moment (I’ve just written a post about that), so it’s very challenging when the ‘attach to xy’ doesn’t appear. In both cases, the ‘attach to xy’ has suddenly become available after many minutes of trying every other route.
edit: I attach an example screenshot


#7

Same here,
The ‘attach to xy’ doesn’t show up when the tab is opening PDF and a corresponding reference is select in the Paperpile tab.

When I see PDF link in the web, right-click pops up ‘attach to xy’ and works nicely.
But there’s more than sometimes that users re-directed to PDF files directly opening in a tab… So, I want the ‘attach to xy’ function working (again)!