PDF annotations private beta 2

Hi Alex,

Thanks for sharing the PDF. I tested it, and it seems to me that your issue is not related to a particular PDF file, but there is something else going on here. Does the issue still persist?


Thanks for reporting this bug. We will make sure it is fixed with he next release of MetaPDF.

Thanks for providing that PNAS paper. It has a lot of superscripts and that clearly seems to mess up our highlighting functionality. I already see myself having a lot of fun debugging this one.

@mpezzo Can you still reprodcue with that particular PDF file? If so, it would be cool if you could mail me the file to andreas@paperpile.com. Thanks!

I just tested a PDF and as soon as I zoomed it, it crashed the entire tab - when back to being a “New tab”.

Tried again with a smaller PDF & same :-/

I’m running Chrome Version 42.0.2311.135 (64-bit) on Mac OSX 10.10.3

What does crashed mean. Did Chrome crash with “Aw, Snap”?

I’ve just emailed you a link to a screen-capture video of error. Don’t even get “Aw, snap” warning!

I just noticed that clicking on a linked reference (i.e. a link that takes you to the references section of the paper) resizes the page such that the reference fills the screen. I am guessing this is intentional but it is also quite annoying. Because I usually keep on reading after checking a reference, I then have to reset the zoom level to page-width. Have you considered removing that feature (if it is intentional)?

Something went wrong!

I opened and made a few annotations to a PDF and then tried to download it. What I got was blank pages with the highlights I made and weird metadata.

This file was synced and I get the messed up file when I click on the “View PDF” of the corresponding reference in Paperpile. I guess it is specific to this file, I have done the same with other PDFs.

Should I send the file to you?


Thanks for reporting. It looks like a case we have seen before. Most likely the PDF is encrypted, and that’s something MetaPDF cannot handle at the moment. Just to make sure, it would be good if you could mail me the file.


@surchs You are making a good point here. We will disable it in the next release.

Hi all - is MetaPDF down at the moment or did it change URL? I’m unable to access https://app.metapdf.com since yesterday…


Yes, I just got an e-mail from Amazon telling me there is an hardware issue with the server. It’s the private beta so we don’t have redundancy or monitoring for this server yet. I need to check what’s going on. Might take until tomorrow to replace the server.

So if anyone else is reading this the server is down for the time being. Sorry for the trouble.

The server is up and running again. I replaced the server and quickly hacked together the service on the new machine.

There might be some issues due to this quick switch which I’m not aware of. I quickly tested and it seems to be running ok. You will need to re-authorize your Google account though. You should be prompted when you first try to open a file from Google Drive or upload a file.

It would be nice if there would be similar highlighting colors and options like in the XODO app for Android.
I use it to read and annotate on my tablet. Unfortunately I cannot use the same colors in MetaPDF as I use in XODO (e.g. orange, all colors set to transparency 25%).

It seems that saving annotations does not work if the PDF is opened for viewing in “regular” Paperpile, at least sometimes. Not sure if this is a bug or intended behavior. On another occasion, had the file opened, and saving worked, so may not be easily reproducible.

If I choose a different zoom level than the auto setting it starts with, I get kicked back to the authentication page from Google and then have to re-load my file. Happens repeatedly.

This topic is now closed. The new beta can be discussed here: PDF annotations private beta 1