PDF annotations private beta 2


#82

Today I found a new bug. I was testing whether the zoom feature affected the vertical offset of the highlight, and quite unexpectedly found that I got highlights that went well into the margins. Could be a function of the pdf file, but I’ve never seen this before. Zoom in Chrome was set to 100%. I don’t know the level set in metaPDF.

  • Mark


#83

Chances are this is already fixed in our development branch. But you can you share with andreas@paperpile.com so we can double check.


#84

@stefan how will the new PDF annotations integrate with the current field “Notes”? Will they be independent of each other or merged (e.g., pdf annotations to be shown on the “notes” field)?


#85

Thank you for including me in the beta. I have just been trying out the private beta of metapdf.

Running Mac OS 10.10.3 and Chrome Version 42.0.2311.135 (64-bit)

I’d like to start by saying I think that metapdf looks really promising that I like the interface and the potential that it shows a lot.

I had some issues with the only pdf I have tried to annotate so far from PNAS it is an open access article so I have sent this to Andreas. pdf available here: http://www.pnas.org/content/109/28/11288.short

  1. On page 11292 I tried highlighting from ‘Furthermore’ to ‘iTregs’ in the second column, second paragraph in yellow and this worked reasonably well apart from appear slightly broken up and not highlighting the full area.
  2. I moved on to highlight from ‘Conditional’ to ‘nTregs’ in the second column, fourth paragraph in red. This really didn’t work very well and highlighted and area larger than the one I intended. I tried to delete the highlighting and this didn’t remove the highlights. To see if re-highlight the same area would work I tried highlighting again in red and ran into similar problems ending up with two layers of highlights as well as changing my first highlight from yellow to red.
  3. Figuring I should just reload and try again without saving I attempted to reload the document, which worked, but left the highlight now in yellow that I made in 1 which had presumably been saved but not the highlight I made in two that I had tried to delete.
  4. I wondered whether I could similarly delete my 1st highlight which I did by selecting the highlight and pressing cross, similar to two above this didn’t delete the highlight, but wondering if it would be deleted when I reloaded I tried to save and sync and this failed. Chrome got stuck in a loop asking whether I want to leave the page or stay, but neither option worked and nor could I switch tabs so I force quit Chrome.
  5. Loading the document via Google Drive in Preview the first highlight I made remained. So I tried to delete this using Previews annotation tools. This was a partial success removing all the highlight apart from the word ‘Furthermore’. I was able to change this to an underline, but could not remove this highlight.
  6. Reopening in Metapdf I tried to delete the underline selecting the underline and then cross symbol. This did not make the underline disappear immediately, but I saved by sync to google drive and reloaded the document and the highlighting was gone.

I hope that this might be of some use to in your development.

Best wishes,
Phytat


#86

Eventually, we will implement our secret “grand unified notes” strategy :slight_smile: That will be a step by step process but in the end you should be able to use notes in Paperpile and the PDF viewer seamlessly.


#87

Is there (or will there be) a way to share annotated PDFs without sharing the annotations?

(Apologies if this has already been discussed…)


#88

@Stefan it seems that MetaPDF is already more useful to me than both the inbuilt Chrome, Drive & Paperpile PDF viewers so it would be great to be able to select it as my default viewer in Paperpile :smile:


#89

Each time I open a PDF (tried 3) from my Google Drive & click the zoom in button, it closes the PDF… There was no issue opening/zooming the same PDF if I go via “Your Computer” button but that’s broken now too. As soon as I click zoom it pops up asking if I want to leave the page, & then closes PDF. I’ve shared one of the PDFs with andreas@paperpile.com


#90

Here’s a screenshot:


#91

Hi
The app looks great! I wanted to report a problem that after annotating and saving my file, then I downloaded it from GD and it was corrupt.
See the images of metaPDF and Adobe


#92

I was wondering if it is possible to make metaPDF the default app to open PDFs from paperpile? Currently, it also doesn’t seem to sync. When I edit with metaPDF in GD and sync it, then open it in PP, it doesnt show the annotations.

Great job guys!


#93

meta-pdf is crashing hard on sync?

This app worked fine for me the last time i used it (a couple weeks ago). Now when i open any pdf from either local machine or from google drive, when it goes to sync it crashes the tab. I’m on a chromebook.

Anybody else seeing this? I love this app but it is unusable for me right now. Any ideas?


#94

Great! :+1:


#95

Found something:

  1. I opened a PDF and searched for a term.
  2. Then I opened another PDF with the search box still open with the term.
  3. When I click on the search box arrows it highlights the positions where the term was on the first PDF.
  4. Search is only updated for the actual PDF when I edit the term in the search box (deleting one letter, for example).

Another question:

What will happen if I merge duplicate entries where one has annotations in the PDF and the other not?


#96

Hi Alex,

Thanks for sharing the PDF. I tested it, and it seems to me that your issue is not related to a particular PDF file, but there is something else going on here. Does the issue still persist?

Best,
Andreas


#97

Thanks for reporting this bug. We will make sure it is fixed with he next release of MetaPDF.


#98

Thanks for providing that PNAS paper. It has a lot of superscripts and that clearly seems to mess up our highlighting functionality. I already see myself having a lot of fun debugging this one.


#99

@mpezzo Can you still reprodcue with that particular PDF file? If so, it would be cool if you could mail me the file to andreas@paperpile.com. Thanks!


#100

I just tested a PDF and as soon as I zoomed it, it crashed the entire tab - when back to being a “New tab”.

Tried again with a smaller PDF & same :-/

I’m running Chrome Version 42.0.2311.135 (64-bit) on Mac OSX 10.10.3


#101

What does crashed mean. Did Chrome crash with “Aw, Snap”?