Performance in Google Docs!

So the slow performance of your document also occurs while you have the Doc opened without the extension loaded (i.e. no Paperpile button can be seen in the menu)? That’s important to know.

If it’s a problem of Google Docs itself (e.g. too many images) we can forget about Paperpile when debugging it and concentrate on the other content of your document.

It is still slow after deactivating PP from Chrome. However, I just started using PP in Safari on the same document and the speed of inserting references and typing is normal. Google Chrome is more convenient as the “insert citation” option in the menu is omitted when accessing the document on Safari.

Yes, the sidebar add-on also works on Safari. It seems really strange though that Chrome is slower than Safari. My guess would be that another extension interferes with Google Docs. Can you try to look at the document in Incognito mode or disable all your other extensions.

It is working now. Not sure which extensions were causing the problem. Just deleted the ones which were not necessary. Thank you Stefan for isolating the problem.

I’ve also faced similar problem and I thought my internet service was slow but after increasing my internet bandwidth I’m having same issue. May be some extensions are causing this problem and glad to get clarification from here.

It seems in case of @mickeylever this was not related to Paperpile but a general issue with Google Docs and Chrome (-extensions). I’d suggest to disable all extensions and open the document that is slow. If that fixes it, you can re-enable your extensions one by one and see which causes the performance issues.

I have the same problem when it comes to documents over 6000-7000 words with 50+ or so footnotes. The longer the doc and the more footnotes there are, the slower the typing. I have to break up longer docs into separate files. The problem is exactly the same on my PC, Mac, and Chromebook, irrespective of whether I connect through Wifi or LAN.

I am having the problem with lag times relating to the length of the document and the number of citations. I have uninstalled and reinstalled paper pile. I have uninstalled and reinstalled chrome! I have deleted all other apps in chrome (ie quizlet, kindle, plex, videostream, etc).

I’m at a loss. It is happening in all my documents.

I’m superbummed as I’ve transfered everything to paperpile. I hadn’t tested paperpiles in text citation tool on anything longer than 1000/1500 words until now. Not sure what to do at this point.


Can verify that you problem is related to Paperpile and contact so that we can investigate this?

We have not heard any complaints about performance in a long time.

I was battling this Google Doc performance issue for several years, but recently found the culprit.

If you have another browser window open that has Adobe Flash on the page, it can slow down Google Docs dramatically.

I often have or open in a separate browser window, which always have flash advertisements. I found that once I close these windows, or other windows with flash, the performance problem goes away in Google Docs.

Wow. That’s unexpected. Actually this thread here is one of the most popular because many people come here independent of Paperpile looking for Google Docs performance advice. So thanks for sharing and I hope that helps others.