Support for PDF annotations

@stefan Great! Looking forward to the new beta. The screenshot you guys posted on Twitter has me excited.

Any chance I can get access to the beta?
Would love to try it out!

@stefan Hi Stefan, Could you please add me to the new beta version? Thanks!

@stefan I’ve been looking for this solution since a long time. Can I please get access to the beta? Your work is highly appreciated.

Once the new beta is out everyone will get access. It’s really imminent now, we have two showstopper bugs left.


@fweWiesel, @Jerlyn_Swiatlowski, @Meriam_G, @nhultin, @vetkong, @raph, @kilpatrj, @LeonQLi , @chjh, @Samuel_Steinberg, @motteh

The new beta is available and all of you now have access:

Please note that this is still a beta version and the main purpose is to collect bug reports and feedback. So please share your impressions once you had a chance to test our new app. Thanks!

Thank you stefan! MetaPDF’s interface is beautiful! I met one problem so far. Only part of the pdf can be shown (about 2/3 vertically) on my laptop. I tried another two installations in my desktop computers, it worked well. All the the computers are Ubuntu 14.04 LTS. Thanks for the great work!

Best, Leon

Hi Leon,

What do you mean by only part of the PDF can be shown? I’m not sure if I understand the problem. You always can zoom the document (page width) so that that the whole vertical range of the document is shown.

It can only shown the left 2/3 of a page, with the other 1/3 on the right hidden on the window. Yes, I tried ‘automatic’, ‘page fit’ and 'page width. None of the worked. I hope I can upload the figure and show it to you. But as a new user, I can’t upload the figure the this thread.

You can send a screen shot to Thanks for helping in debugging.

I’ve also changed the forum settings. So you can share the screenshot here on the forum.

@stefan It seems I still can’t upload image as a new user. Anyway, I have sent a screen shot to @andreas through email.

Thank you guys!

Thanks. Still it’s strange that this forum settings does no work properly. In any case I’ve made you a “not new” user so your uploads should work now.

Thank you @stefan. I have reported the bug through email.

We think it has to do something with the zoom level of the tab. Can you check whether your tab is zoomed to level 100%:

the zoom level is 100%. The problem is still there.

We’ve identified the issue. It has to do with some zoom level metric on high resolution retina displays. We hope to fix this soon. Thanks so much for reporting!

Please add me too! Would love to try this feature


I have added you.

Thanks but how do I access the feature?