"Always include DOIs and URLs." option is ignored

I have it checked, and I do have URLs and DOIs for the items in my bibliography, but they are not displayed in the references list. This appears to be a bug.

Observed for “European Journal of Radiology” citation style.

Paperpile only shows DOIs if the CSL file contains DOIs. Paperpile’s option does not override styles (there is no way to do that in a consistent way that is correct for all styles).

Please make sure that the style has DOIs implemented, if not you can add it to the CSL file using the CSL file editor http://editor.citationstyles.org/

Thank you for clarifying this Stefan. I apparently was confused by the text associated with the checkbox.

Agreed, it is confusing but the whole situation with DOIs and CSL is confusing and it’s not easy to come up with simple terms to describe it. Here is our attempt from our help pages at https://paperpile.com/help

For most reference types Paperpile lets the citation style control how to display DOIs and URLs.

However, for print articles Paperpile does not show DOIs or URLs by default. More precisely, citations of types “Journal article” and “News article” with the field “pages” set will not include DOIs or URLs.

To override this behavior, activate the option “Always include DOI and URLs”. This option will show DOIs as specified by the citation style. Note, that some citation styles don’t support DOIs and this option (despite its name) cannot change that. You may need to adapt the behaviour of the citation style by editing the CSL file (see above).

You can store multiple URLs in the field “URLs”. Paperpile will always use the first in citations.

The Option in the current Word plugin is called “Always include DOIs or URLs.” (not “and”).
So I thought it would show the DOI/URL depending on the presence of the variable in the reference.

But it will include both and when I delete the URL field in the reference PP will just generate a dx.doi.org link and insert it as the URL.

Is this behavior intended?