Anyone using Paperpile with Arc Browser successfully? I can't get it to download papers

So I finally found a browser that I prefer over Safari–namely, Arc Browser. I thought I could finally use one browser for everything, as opposed to using Safari for nearly everything and then Chrome or Edge for certain things that don’t work in Safari.

BUT! Arc Browser (based on Chromium) doesn’t work nicely with Paperpile. In particular, the ‘Find PDF online’ feature doesn’t trigger any actions at all, whether in the new version or the older version of Paperpile. If I try this in Chrome it works perfectly. I don’t know what accounts for the failure in Arc.

Anyone using Paperpile with Arc Browser? Did you have to do anything to make it work?

Paperpile staff–any help with this?

Thanks :pray:

1 Like

I’ve recently starting using Arc browser as well but have not experienced any issues with downloading articles. No additional setup required other than installing the Paperpile extension. Perhaps try removing and re-adding the extension if you already have it. I also haven’t experienced issues with the ‘Search Online’ feature directly in Paperpile

@hug101 A member of the team signed up to try the Arc browser, but he is still on the waiting list, and so we haven’t been able to test Paperpile on it. However, other Paperpile users have tried the new Paperpile in Arc, and it has worked for them. One user contacted support with the same issue you are having, and they found that switching the extension off and back on again worked for them.

Thank you! I did as njd suggested and removed the extension entirely (disabling and enabling didn’t do anything) and updating the browser and reinstalling and it worked!

Suzanne–If your team member needs an invite I have one left so just shoot me a message and I’ll hook you up.

1 Like