Button not appearing at Google Scholar

Hi team,

When I query at Google Scholar or Google, I can not see the Paperpile button next to the search result though I’ve enabled the option at the setting.

The extension works well for other site(e.g. PubMed).

What should I do to fix it?


Welcome to our forum, @Miki_Katsuragi! Thanks for the report. Have you refreshed / restarted the browser, signed out and back in of your Google account, perhaps tried clearing cache and cookies? The same is not happening on our end.

Our languages differ but I don’t think that would affect button display. Let us know if the issue persists.

Thanks @vicente for the clarification!

I restarted the browser in addition to using incognito window, signed out and back, cleared the cookie but the button is not still appearing.
Modify display language to English did not resolve the issue, too.

I realized the button is displayed on the extension after opening the link from Google Scholar search result.

Am I missing something?


Thanks for the details, @Miki_Katsuragi. Quite puzzling - still no luck reproducing this on our end, even switching languages. Do you have any other browser extensions installed? If so, turning all off and only Paperpile back on would be something to try. If you’re able to use other Chromium-based browsers (like MS Edge, Brave, Vivaldi…) it would also be worth checking if the same issue occurs there. Let us know.

I’m also not seeing the button on Google Scholar’s results page. I do see the buttons on PubMed results lists, so it’s not something wrong w/ the extension.

Maybe there is something region-dependent about the Scholar results page that’s causing the variation?

@Gregory_Jordan I think the extension can sometimes respond differently depending on the site - in the past, the buttons have disappeared from PubMed alone, for example. Are you able to try from any other Chromium browser like I mentioned above? A regional setting/characteristic would also make sense to me but would have to be a recent change (since we haven’t gotten more reports like this).

Thanks Vicente for the quick reply.

I did a bit more digging and I think I understand what’s happening.

The Paperpile extension was failing to load at all on both scholar.google.com and google.com. Two symptoms: (1) the pop-up button was showing the “Waiting for page to load…” message even after the page was fully loaded, and (2) the extension background page showed an error message “This page cannot be scripted due to an ExtensionsSettings policy”.

Reading up on that message, it seems this is a restriction that can be applied to managed Chrome browsers (Configure ExtensionSettings policy - Google Chrome Enterprise Help).

I had been trying on my work-managed laptop. Switching to a different machine w/ the same non-work Chrome account, Scholar buttons showed up fine.

I wonder if @Miki_Katsuragi was encountering the same issue.

1 Like

Any update on the issue of the Paperpile button not appearing in Google Scholar search result page?

I am trying to use the Paperpile extesion on Chrome on my new Windows 11 PC, and am experincing this same problem. When I restarted the extension by switching the it off and on in the Chrome menu, the buttons actually appear on the search result page, but when I reload the same page, the buttons disappear. Exactly the same symptom with PubMed. I tried restarting the browser, signing out and back in of my Google account, and clearing cache and cookies, but the problem persists.

I never had this problem on my other PCs (Windows 10).

PS I rebooted the PC, and the problem seems to have disappeared!

1 Like

Thanks for the follow-up, @Yoshi. Please don’t hesitate to reach out here or via chat/email (support@paperpile.com) if this happens again or you have any other questions.

1 Like