Conference paper type omits the location of the conference

Per APA, conference papers should show up like:
Author last name, first initial. (Date). Title of contribution [Paper presentation]. Conference Name, Location. DOI or URL but as you can see, paperpile refuses to show the location. What must I do to fix this? For now, I had to change the type to Presentation, which is not actually correct but solves the problem temporarily. I ought to be able to choose the correct reference type, but Paperpile seems to be broken in this regard.

Hi jdev, in the PP app, edit the paper. At the bottom there is a button “additional fields”. Click on that and you will find the field

The field is already there and filled out, see screenshot. The reference type simply does not work properly.

Since this conference paper is published, following the APA7 guidelines, Paperpile views it as “Conference proceedings published in a journal”, and so, the citation in the bibliography does not require the location, @jdev. Per these guidelines, in your screenshot above, the paper does appear to be formatted correctly, except that the DOI is missing. You’ll need to select the “Always include DOIs and URLs” checkbox in the citation style dialog for it to be included.

Thank you for that, I wasn’t aware. It is frustrating that I have to make an entire new document in order for the “alway include DOI” option to be available to me. Furthermore, every single reference in the new doc, I still have to click "additional fields and pick DOI. Why on earth won’t it just include that field when I have done the “always include DOI”? I am exhausted from clicking this, scrolling down, find the DOI field. Is there some way to tell paperpile to just show me the DOI field?!

The DOI (if available) should be collected when importing the paper using the Chrome extension. How did you collect the metadata for the references missing DOIs? Is there a common source (e.g., journal) for the references missing DOIs?

To speed up the process of obtaining the missing DOIs, you could try using the auto-update feature in the web app. Select the papers with missing DOIs, click the drop down arrow menu, and select Auto-Update.

In the new web app, for which we’ll be calling for beta testers soon, it will be possible to autocomplete DOI data directly in the metadata edit dialog. Finally, the request to customize the default fields shown in the edit dialog has come up before, and I’m adding your +1 to our internal tracker.