Critical: PDF sync does not work reliably


#1

I recently had to re-install the OS on my mac, and after that I seem to have lost the ability to sync annotations done using MetaPDF.

I have “auto sync” turned on, and I also tried forcing sync via the menu, but the sync indicator circle remains non-filled.

When I open the developer console in Crome, I see a log message after manual trigger of sync (" SYNC Starting sync."), and then immediately “SYNC Scheduling next sync in 30 seconds.”.

Please help!


#2

After a long long long wait (see below) the sync was finally done …


#3

I’ve just noticed that something is not quite right with the sync of PDFs that I add to Paperpile. I added a paper with a PDF few days ago, and when I click on it, it fails to open in MetaPDF. Looking at the PDF details in Paperpile, I see it has not been synced. How many days do I need to wait for the sync to complete? Can someone help with those sync issues?


#4

Syncing is more or less immediate. If it does not sync, please restart the Chrome extension, reload the tab and check what the little drive icon on the top right says. If there is an issue it should show a red exclamation point with instructions.

Also I’m not sure what you mean when you are talking about “MetaPDF”. That’s the name of the standalone version that runs on metapdf.com. We don’t recommend that to use together with Paperpile.

With Paperpile you should use the built in PDF viewer (which is based on MetaPDF) but more regularly updated and will be replaced soon by a brand new version that uses a different way to sync.


#5

This is what I mean - see below. Is this what you are not recommending? If you don’t recommend it, why is it listed in the Paperpile settings?


#6

No that’s fine of course. I was just confused because you called it “MetaPDF” a name we never refer to in Paperpile.


#7

I’m trying to access my PDFs in Google Drive and noticed that the majority of the PDFs that I have on paperpile.com are not in my Google Drive folder. I have auto-sync turned on and it tells me that everything is synchronized, but the files are not there. For example, one paper I’m trying to access is “Leal and Yassa 2014 - Effects of aging on mnemonic discrimination of emotional information.pdf”, so I go to the Paperpile folder in Google Drive then All Papers and then L. The paper is not there. I can open it in the online viewer at paperpile.com and I see the “All changes synced to Google Drive” messages and that auto-sync is turned on when I click on the File button on the top left.

I’ve tried to restart the chrome plug-in and force the sync, but still nothing. When I click on the Drive button on the top right of the main page and select “View all Files in Google Drive” I only get directed to https://paperpile.com/gdrive-folder-not-found. I’m really not sure what’s going on here.


#8

Indeed, it does not work reliably. @stefan sync is not “more or less immediate”.

I uploaded PDF manually, and upload completed, but it does not seem to have sychronized with google drive.

What is confusing and counter-productive is that PDF can be opened in the viewer, and I can start annotating it, before it is synced up.

Google Drive icon in Paperpile is not filled:

and I think this is why I am unable to save my annotations:


#9

@stefan how am I supposed to restart the Chrome extension?

Just earlier today I was able to add a paper to paperpile by clicking the extension button, and it properly uploaded the PDF to Google Drive. Now, when I manually attach a file, the Drive icon in the Paperpile right hand upper corner reports error:

I’ve just tried with another paper, and it does not upload the PDF properly when clicking the extension button directly.

I restarted Chrome, it didn’t resolve the problem.

Please help!


#10

I tried uninstalling the plugin from Chrome and then reinstalling it. It seems to have fixed the problem that I got when I would click on the “View all files in Google Drive” button. It now correctly pulls up the Paperpile folder in Google Drive.

It also made it worse for accessing files in the Paperpile web viewer. Before doing this, I was able to view PDFs in the Paperpile web viewer even if files didn’t show up in my Google Drive. Now I can only view files that are available in my Google Drive. If I click on “View PDF” for the files that did not get synced into my Google Drive, I just get an error saying “Something went wrong – could not open file.”

I tried forcing a sync and Paperpile tells me that everything is synced. The files are still not in my Google Drive.

I tried trashing the reference I mentioned previously and then going back to Google Scholar to add it. It found the PDF correctly and synchronized with Google Drive now.

It seems like unless Paperpile can figure out what went wrong, the only fix is to trash references that aren’t synchronizing individually (make sure to download all the PDFs if you have annotations or you will lose them) and then go back and re-import them. Extremely tedious and time consuming, but might be the only solution.


#11

@dkbjornn thanks for your report. This is very annoying…

They have not even admitted there is a problem, so I think we are quite far from it being fixed …


#12

@dkbjornn @Andrey

Unfortunately there is no general “problem” we can admit to. I wish there was, because then we could would have fixed it a long time ago.

But there are lots of moving parts in Chrome, Google Authentication,… that lead to rare constellations so that sync runs into problems. In the vast majority of cases the little exclamation point will tell you what do do. E.g. wait and retry when we encountered an error on Google’s servers (that happens and there is nothing we can do). Or re-authenticate Google Drive when for whatever reason Paperpile lost the access to your Paperpile folder.

In the rest of the cases, restarting the Chrome extension (Three dots menu > More Tools > Extensions: Disable/Re-enable the Paperpile extension) should help.

If also that does not help, we need to look into your logs and find out what’s going wrong. That cannot be done on the forum, so please contact us via the in app messenger.


#13

Thank you @stefan!

Can you give us instructions how we can retrieve the log to send to you, when it happens next time?


#14

@stefan the issue keeps happening. Can you give us instructions how we can retrieve the log to send to you?


#15

@Andrey Can you send us a quick note in the in app messenger mentioning “Stefan”? I’ll take care of it personally (the forum user names are not directly linked to the user database so I can’t reach out directly).


#16

Thank you, I will do this next time it happens. Thank you!


#17

I have a similar problem and noticed a few weeks ago that my pdf’s had not sync’d with Google Drive since June! I tried everything suggested here, re-authorized Drive, turned the extension on and off etc. I even got a new laptop recently, completely new setup and the same problem still. I removed all the references with pdf’s that had not sync’d but still, it does not work, any new files added do not sync. Interestingly, in the settings under Google Drive storage it says ‘Paperpile usage: 0 KB in 0 files’ although I have >1,500 files in there. If you found a solution please let us know; as much as I like Paperpile without sync it’s useless


#18

It is very random. Today I was annotating a PDF, and sync was not working for the document I was annotating. No errors, just does not sync.

I guess “the solution” is open the document, try a test annotation, try syncing - if syncing does not work, don’t waste your time and open the document for annotation in some other tool …


#19

Please not that the the web based annotator is still in beta (for a reason).

We have re-written the Google Drive sync from scratch to have more reliable sync for our web-based annotator and the mobile apps. Since it’s January 3rd, I feel safe to say that this will be released this year :smile: