Force paperpile NOT to use a local copy


#1

Help!

I’m editing my PhD thesis trying to get it ready for submission…

I love paperpile for its ease of use, but I when editing the latest chapter I noticed that corrections I’d made in my paperpile library to titles of papers etc. that appeared in a draft bibliography have not been updated when I reformat my references in the google docs file.

I now know that there is some sort of local copy for the references associated with that google docs file.

but I don’t want it to use the local copy… I want to force it to use my library copy as thats the one I have edited with the corrections to titles, journal names etc.

Is there a way to stop it using the local copy and force it to use my library instead?

Thanks


#2

Don’t worry about the local copy. If you are editing your thesis alone Paperpile will always use the latest version in your library (you need to reformat the bibliography it is not updated in real-time).


#3

Hi Stefan,

That was what I was doing… I had reformated the bibliography… I even deleted the old reference list and then got paperpile to recompile it, but none of that works.

It still has errors in titles that when I click to look at the reference from the document shows a reference listing that is different to the same paper in my paperpile library. It says it’s a copy that is local to that particular document… but I don’t want it to do that I want it to obey the changes I made to my main library without having to go through and edit each reference individually.

Edit: just went to a reference that is wrong in my googledocs file and clicked open then on edit and at the bottom of the listing it says this:

“This is a local copy specific to this document. Any changes made here will not update the copy in your
Paperpile library and will prevent any updates of this item in your library to propagate back here. Learn more”

I’m the only person who edits this document in googledocs, although I do so on multiple machines depending where I am (Home, work, the lab etc) but they all use the same google login.


#4

Again, the default behaviour of Paperpile is exactly what you want.

The most common reason why you might not see the updates in your document is that you have duplicates and you are editing duplicate A in your library and have cited duplicate B in your document.


#5

Checked and there are no duplicates in my library of the references that are in this chapter draft… I’m very good at making sure that I don’t duplicate and do a regular library cleanup.

I have a duplicate in the document of a paper that only appears once in the paperpile library (wilson 2012a and wilson 2012b) same paper and only once in my library but it puts it twice in my bibliography for some reason… but thats not a problem, I can sort that. It’s the references where I have purposely changed the titles to not be all capitals, or removed spelling mistakes etc. or the journal titles where I have corrected them to not include the journals sub-title as well as it’s main name. All those still appear incorrect and won’t update to reflect the changes that I’ve made to my main library.

I know that this is supposed to be the default behaviour… but it isn’t actually doing what it’s supposed to and I want to force it to do what its supposed to. Tried updating etc. but to no avail… my last resort is to copy the text and then re-insert the references again (but thats a horrific prospect as this chapter has nearly 300 references in alone!)


#6

The only other explanation is that you have edited the data not through your library but directly in the “local copy”. In that case the edits there will remain and the edits in your library will be ignored.

If that’s not the case that’s a new problem we have not seen before.

Can you verify that when you insert a new citation with title “TiitleA” and then change it to “TitleB” in your library and reformat the bibliography it’s still “TiitleA”. I can do this right now without any problems so this is definitely not broken.


#7

yeap I think thats whats happened… is there a way to turn off this functionality and make it update from the library? I suspect any edits in the document are minor (or even just me accidentally deleting something in the inline reference and then putting it back so loosing any changes isn’t a problem - I will be going back and checking them all in the final draft anyway.

Also the in document edits… does that include adding prefixes etc. to a reference? I use that a lot for images where I add “after” or “adapted from” as a prefix to the first reference in the image caption and then usually a page number as a suffix to many of them.

These minor issues aside, I still think paperpile blows Endnote et al. out of the water!

Many Thanks.


#8

I was not talking about the edits in the document (these are completely ignored).

If you click “Paperpile > View all references” you get the list of references in that particular document and if you edit the metadata there it will override subsequent edits in your library.

Did you do that?


#9

Not that I am aware of. However to be honest this chapter was first written two years ago as part of my transfer report then has been reworked quite a few times since as I filled it out and added areas that I hadn’t previously covered.

In all that its possible I did something ages ago that caused the issue.

I copy the text out into word and then format it there for a draft. but I edit the text back in googledocs when I get comments back from my supervisors rather than copy and paste over from word… but thats not to say I didn’t slip up at some point in the past. Would coping the text (with it’s paperpile references) over to word and then later back into googledocs cause the issue I’m having?

I have a work around… my editor (my wife) has been going through the references of each chapter and editing the paperpile library to get rid of issues. Then at the end we are going to create a single brand new googledoc and insert every reference into from each of the chapters before formatting it using my custom CSV to create my references section… its a bit tedious but won’t take more than a couple of hours and at the same time we can use it to make sure there aren’t duplicates and BSEs (Bloody Stupid Errors). It has the advantage that I can keep the chapters separate and not have to paste them together into one big document and the changes are universal and I don’t end up with the same references edited multiple times when they appear in multiple chapters…

Anyway, many thanks for your help as always.


#10

I had a similar problem with a manuscript I was just editing. I would review the reference list, see an error (or missing info), fix it in my Paperpile library (NOT the local copy, the actual library) and then when I updated the citations (using the Paperpile add-on in Google docs), it wouldn’t update. The only way I could get it to update was to exit the document and PP, then reopen the document in Google docs, and press update. Very annoying.

And–it seems as if this problem is not consistent. Yesterday when I was editing the same document, it would update. I am working on the same document, same computer, logged into the same Google account. So what was the difference between yesterday and today?

Thanks for your thoughts on this.


#11

As I mentioned above the most likely explanation of this behaviour is that you have duplicates and you are editing duplicate A in your library and have cited duplicate B in your document.

In that scenario you would not see the updates on one day and when you work on another citation on another day it would work as expected.


#12

Actually, I know that is not the case. I am somewhat fanatical about being sure there are no duplicates. I use the button on the right and resolve them immediately.


#13

I had the same issue. The work around that Leslie_Nicoll gave did work for me. I exited the document and signed out of PP in the browser. Then signed back in and reopened the document. Then updating the citations resulted in the Paperpile library version of the reference.


#14

I am facing exactly the same issue as described. How can i force Paperpile to use data from my central database. It is not applying updates that i made in the central database. And no i did not make them in duplicates… (In another note I think this part of paperpile has some design faults, it is very confusing that i can make an edit to a local database instead of the central one… I get that you want to support collaborative work but there are better ways to implement this)


#16

To re-create the link to your library do the following:

  1. Remove the in-text citations to the paper.
  2. Go to Paperpile --> View all references, in the Google Docs menu. Remove the paper from the resulting page.
  3. Re-insert the citation as normal.

This is not ideal for many references, but is more workable if the problem is affecting just a couple.