IEEE Word template corrupts references


I’m using this IEEE Word template (A4) to write a paper:

Adding references, saving and closing the file seems to work fine.

When I open the file the references will look fine at first.

But when I try to add a new reference or update the existing ones they’ll get corrupted.

The inline citations get replaced with “[Citation error]” and the citation list just gets deleted and only the newly added reference will be there.

Is this some bug or is this specific template somehow interfering with the PP plugin?

I have tried adding references to an older paper which is based on a previous version of the IEEE template and that one doesn’t seem to have this problem.


I assume you are using our Word plugin (the linked page also contains LaTeX templates).

@ttrepka Can you try this. If there is something special in this template it will most likely affect our plugin in outher circumstances.

yes, I’m using the Word Plugin and the Word template.


I’ve tried it again with the latest update of the word plugin and it still shows this behavior with this specific template.

I’m also using Office 365 on the insider channel, not sure if this might be causing it.

But as I said an older template from a previous paper which I used now instead works without any problems.

Hi Daniel,
I tested with the A4 template and I can confirm it’s happening, no matter which version of our plugin you use. What happens is that we store hidden data about each publication in Word “ADDIN” fields. We need this data to generate correct citations and bibliography. This specific template somehow removes all the hidden data when you close and reopen the document (the texts of the citations remain but it all breaks when trying to reformat them).
There must be a specific setting in this template - I tried creating a new empty document and copying the contents of the template and it works just fine. However, I can’t find any such setting that would cause removing the field data.
I’ll continue investigating. If you have any idea what might be causing it, it would be appreciated!


1 Like

Thanks for checking it out.

I have no idea what is causing it, I went around the problem by taking a paper from the previous year and using it as a template. The strange thing is that the old paper probably was also based on the January 2019 IEEE template, but I can’t tell/remember what I’ve done to the tamplate back then so that it turned out working (or if it is in fact based on the current template).

Thanks @ttrepka for looking into that.

In principle it makes sense to strip out all meta-data from a Word document before you submit it. But if that’s really a feature of their template somehow it’s not really useful while you are working on the manuscript.