Import annotations from Mendeley

I imported my Mendeley library to Paperpile but when I open the documents I cannot see my annotations. I tried opening in the beta pdf-viewer (the default one doesn’t work in Chrome for me) and in the Android app. I considered paying for Paperpile but I don’t want to switch if I cannot access my notes on the old papers. Is the import possible?

1 Like

Welcome to our forum, @Victoria_Bessonova! Thanks for reaching out here as well as via chat. Unfortunately, importing from Mendeley won’t include annotations because they’re not written directly in the PDFs and we haven’t figured out how to fetch them from Mendeley servers. We are looking into solutions for this and hope to implement the possibility over future updates - adding your +1 to our internal tracker to raise the topic’s priority for the team.

Other users have been able to successfully export the PDFs with annotations via Mendeley’s desktop app and upload them to Paperpile, in case that’s an option for you.

Hi, I’m having the same issue. I tried exporting PDFs with annotations from Mendeley (I know they have exported correctly because I can see them in a different PDF viewer), but the annotations (highlights and in-text notes) do not show up when I upload the PDFs to Paperpile. Without this feature, I cannot migrate completely from Mendeley because I have many notes stored there that are important to me. Hope to see this in an update soon!

Welcome to our forum, @Jenelle_Wallace! That’s strange, would you mind sharing a few of these annotated PDFs with us so we can try reproducing the behavior on our end? If you exported them in a way where the annotations are saved/written directly on the file, they should show up in Paperpile. You can send them via chat or email (

I believe I have solved the problem - when I imported the whole library following the directions here Migrate from Mendeley | Paperpile Help Center (version for " If your library is not synced"), the annotations did not import. Later I went back and just manually uploaded all of the annotated pdfs and it looks like they got associated to the correct papers and the annotations are there. It looks like for some papers, the annotated pdf replaced the original and for some a new pdf was created (maybe dependent on whether I had also added annotations in Paperpile?), but I’m fine with that.