Import paperpile json

Hi team,
Is it possible to import bibliography and related data from the JSON file generated by Paperpile itself?

I have recently saved my whole library to JSON and then needed to switch to an institutional account, thus losing all papers stored in my library so it would be great to be able to restore them from the JSON.

Thanks!

Thanks for the query, @Edoardo_Giacopuzzi, and apologies for the delay here. Yes, you can definitely upload that JSON file to any Paperpile library to import the references it contains - hopefully you’ve tried it already by now. Feel free to reach out again if there’s anything else.

Hello vicente.
I’ve exported the complete JSON from user > settings > export in the Paperpile app. However, now it is not clear how can I import my library back from this JSON.
If I try to load it using “add papers” > “upload files” the app do not recognise it and I can’t see another place where I can upload the JSON file.

Can you please give me instructions on how to restore my library using the JSON file?

Thanks!

Edoardo, did this continue to be the case? The workflow you described is the correct (and only) one - our importer recognizes JSON, BibTeX, RIS, XML and PDF formats.

Sorry again for the long delays – oversight on my part alone. Please let us know here or via chat / email (support@paperpile.com) if you continue experiencing issues with this or have any other questions.

Hi,

I’ve tried multiple times to import the JSON without success.

When I try importing it as a .json file, Paperpile uploads the file but then refuses to process it, reporting “xxxx.json is not a supported filetype. Please choose a different file”
If I rename this to have a .txt extension like in your example, the software imports it, but no papers are added to my library and I get this error.

File Error
An error occurred while processing this file. Please try again or contact Paperpile support if the proplem persists.

Have you been able to actually import papers using json? If so, how? What am I missing?

@Edoardo_Giacopuzzi, could you please share the actual JSON file via chat or email (support@paperpile.com) so the team can take a look and troubleshoot as needed? Sometimes there are specific reference items causing issues. Let me know.

Hi @vicente just want to check how this issue is solved. I run into the same error. No paper was imported.

Thanks

@Bing_Mao welcome to the forum! Please share the JSON file with us via chat or email (support@paperpile.com) so the team can examine it and troubleshoot.