Issues with Loading PDF files

Starting from last weekend, I had issue with loading PDF files. When I click on “view PDF”, a button says “Loading PDF”, which is followed by “Still working”. But nothing else happens. It also fails to copy the reference, and fails to allow me to manually upload a PDF file (The link for open a dir is missing). I have rebooted my computer and cleared ‘browsing data’ in Chrome and the problem still exist.

This is on a desktop with good internet connection running Linux Chrome Version 41.0.2272.16 beta (64-bit). It has no issue if I use google-chrome-stable on the same Linux Machine. On my laptop running chrome 39.0.2171.99 (64-bit) Linux, everything is fine.

1 Like

I’ve sent out several messages to users on the beta channel. In addition, I’ve also sent you a personal e-mail on Sunday. In case it got lost:

You are running Chrome beta version 41.

This version introduced some changes that breaks Paperpile.

As of writing this message (Sunday, Jan 25), Paperpile cannot be used on Chrome beta.

We’ve fixed the problem already, but such a fundamental change how Chrome behaves requires more testing. We cannot risk breaking things for 99% of our customers who run Chrome stable. We have scheduled the release of the fix for Sunday next week (Feb 1).

Thanks to all who reported the issue.

1 Like

Thanks for the response. I did not see your earlier messages after I sent the report via emails to the support email address. I’ll switch to chrome stable for now.

I just want to confirm that this issue is solved for chrome-beta. Thanks!!

Thanks for the follow-up. Also thank you for being a beta-tester here. It’s really helpful having a small fraction of users on beta to see in time when things might break.

PDF viewer stopped working for the new chrome-beta Version 42.0.2311.39 beta (64-bit). PDF files load, the note window shows but there is no display of the PDF. The center of the page is the same as the background. Same pdf file works fine on chrome-stable.

Thanks! We’ve reported the issue to Google and I’ve sent out an in-app notification to all users on the beta channel:


Can you please add me to the beta channel? I seem to report google-chrome-beta issues with a few days of delay and cause extra work for you.



That’s done automatically depending on the user agent string your browser sends us. If you use both stable and beta it can be that Intercom (our support communication tool) thinks you are on 41 even though the next time you log in with 42.

I have this issue with the latest Chrome version.

When my notebook resumes from standby I always have to reload the Paperpile tab, otherwise PDF files won’t get loaded/opened.

Searching seems to work normally though.

What operating system and browser version are you on?

Windows 10 x64 1903.

Chrome 77.0.3865.120, but I’ve just updated to 78.0.3904.70.

I can replicate the problem by putting my notebook into standby and switching it on again.

I can normally browse my lib.
But when I try to open a PDF nothing happens, the “still working” toast appears at the top.

This may be the timeout problem. I.e., if you go away from your computer for an extended period of time, the host computer ‘forgets’ that you were ever there. You have to close out of the PDF and reopen. You might possibly get it to connect by reloading the page.

I should add that this problem is a byproduct of the design of the internet. IOW, the internet is a transaction design - computers side idle waiting for an input from other computers. Hosts deliver a webpage when a user requests that page. Hosts expect follow-on requests when a new webpage is opened. However, hosts are usually not informed when you close a browser, so those open pages are wasted memory. That is why hosts will close pages after a certain amount of time.

I’m aware how things work… but I don’t think this is normal behaviour.

Also working inside already open PDF tabs works after standby, that offline bug has been resolved in one of the recent updates. The webapp itself also re-established a connection to the server, which it indicates with an info message.

This is why I think that all the “Open PDF” buttons not working unless refreshing the page seems to be a bug. Maybe it’s a technical limitation of the Chrome app, but that would be strange and that’s why I’m asking.

The most likely reason is that Chrome somehow suspends the Paperpile extension and the Paperpile Web App can not contact the Paperpile extension. We are currently trying to replicate this behavior on one of our systems.

1 Like

I think I narrowed it down to my Chrome installation.

I tried to reproduce it on my Surface Go (same Windows build, latest Chrome version).

It works normally there. I also tried it with Opera on my Notebook and it worked normally.

I wiped my Chrome cache and restarted Windows, now it seems to work normally.

Should have tried that from the start, thanks for your efforts and sorry for kinda wasting your time…

I can recommend using this software to edit and load files in PDF format, I think it may help you. Well, this service helped me several times when I had the same problem.