Metapdf CPU usage

In the last week or so I’ve noticed very high CPU usage while annotating pdfs in metapdf (consistently around 50% with the metapdf tab open). I just started using metapdf more for my work/research recently, but don’t remember this being a problem the few times I had used it previously. The problem doesn’t seem to be limited to one specific pdf or machine.

We hope to release a version in the upcoming weeks that should fix this issue. Do you see this behavior also in Paperpile when annotating PDFs there, or is it just on

Good to hear. And yes, just on That may be why I didn’t notice it before…

Deactivating GPU-Acceleration in gChrome solves this issue (for me) and furthermore the tab doesn’t freeze anymore and scrolling works smooth again.
Try it out and share awareness.

Still not solved. And it’s starting to annoy me beyond acceptable levels.
Do you need more info to find the bug, or how could I help?


Are you using the Paperprile integrated viewer or

Slightly old thread, but this is still happening. I am currently using the viewer with the ability to highlight.

1 Like

The same thing keeps happening to me when viewing a scanned PDF file containing OCR-generated text in paperpile (Viewer with annotations). Deactivating hardware acceleration in Chrome sure helped, but there is still a peak in CPU usage and the viewer is still much slower than with non-scanned pdf files.

I noticed that, when opening problematic (slow rendering) pdfs and highlighting a passage of text, each word seems to be marked separately, which is different from the viewer’s behaviour when opening non-problematic (fast rendering) pdfs. Maybe the issue is connected to the way text in documents with OCR is rendered?

1 Like

Was facing the similar issue, take a look at some of these solutions:

  • Clear Event Viewer Logs
  • Download and install all available Windows updates
  • Scan your computer for viruses and malware
  • Find and Disable the service that causes the “svchost” high CPU usage problem

See brief solution here:

Alter the address of DNS IP
then Flush the DNS
Restart the DNS Client
it will resolve the DNS_PROBE_FINISHED_NX DOMAIN error in Android

for more query visit