MHRA style is not inserting "ibid" where the citation is the same as previous?

PhD student new to using a citation manager, and new to using Paperpile.

So I am wondering why when I set the default style & Document Style to MHRA it doesn’t insert “ibid” for footnotes referring to the same source as the previous? Is there something i need to change?

I am pretty sure this is required for MHRA

From what I can gather, there is an ongoing debate about whether ibid should be used or not. As a result, many styles t\do not implement ibid rules.

That said, here are modified MHRA styles which use the ibid rule.
mhra-note-ibid.csl (16.0 KB)
mhra-author-date-ibid.csl (10.6 KB)

To add them, go to the gear in the upper right --> Settings --> Citation Styles --> Upload CSL file.

It is useful for me i have many problem make ciatation paper