Paperpile does not work with new ACM Digital Library design

Since the ACM Digital Library has rolled out their new design, PaperPile no longer correctly detects or adds papers from it. It does not detect already-added papers as existing in my library, and it adds new papers as websites.

Is this a known issue? Progress on fixing it?

Unfortunately I’m having the same problem. As far as I can see, there is also no way to go back to the old design as well

@mdekstrand, @pfandzelter, is this still happening? I just navigated to a random article and was able to add it to Paperpile. Of course, I’m not logged in and assume you both are.

If that’s the case and it’s still not importing correctly, let me know and I’ll consult the dev team.

It looks like the following features work:

  • Adding journal articles
  • Detecting that a journal article is already filed, when it has been added under the new system

These do not seem to work:

  • Adding conference articles (e.g. is added as a web page)
  • Saving the PDF from a journal article (e.g., when I am on my university’s network using their subscription; clicking the PDF link works)
  • Detecting a journal article has already been added, when it was added by other means or under the old interface, but includes the DOI (manually adding the modern DOI-based URL to the list of web URLs does cause it to be correctly detected, but having the DOI field correctly populated is not sufficient)
1 Like

Thanks for the details. I’ve asked the dev team to take a look, but I’m afraid it might just be a matter of waiting.

These ‘broken paths’ are usually related to internal changes involved in the new design. In other similar cases I’ve seen, issues appeared intermittently during the first few weeks after the change and were cleared in subsequent updates.

Wanted to follow up with current status here. Things keep changing, but still generally don’t work, and arguably are more broken now - if I add a conference paper, it gets added as a journal paper, and auto-update to get the detail doesn’t work (even if I manually put the DOI in the DOI field of the entry).

Same problem here. I was able to add the references by using the “export bibtex” feature on the ACM DL and then importing to Paperpile. Then I tried adding the PDFs through Google Search, and I get a “PDF restricted” error. I also tried adding from the ACM DL page as @mdekstrand mentions and using the “browse manually” option for adding PDFs. In all three cases, I can access the PDF, but Paperpile cannot.