Paperpile froze during setting up library

Hi Paperpile,

Apologies for cross-posting because I had also sent an email to the Paperpile support inbox. I thought posting here might get some support from others as well with similar experience.

This morning, I noticed Paperpile did something strange when I tried to move two papers to another folder. It kept reverting back to the old folders. I tried restarting the Chrome browser but no luck. Then, I tried deleting my cache, downloaded files including hosted apps, log out from Paperpile and restart Chrome.

After logging in to Paperpile, a screen said Paperpile is setting up my library…but it froze with the following browser error:

Unfortunately, I am unable to get to my library now. Is there any other way that I can continue using my library while this issue is ironing out?

Note: My library has ~7800 papers so perhaps it is an issue here???

Please advise.

Safari seems to load okay. Although it also takes a while initially when setting up the library.

Ok, I have tried the following and I am able to access my library now:

  1. Uninstall the paperpile Chrome extension.
  2. Delete browser cache.
  3. Restart Chrome
  4. Go to paperpile website. It will prompt installing Chrome extension but I ignored it, and the loading completed.

We’re sorry for the inconvenience caused by this issue, @zhao.paperpile. The team will be releasing a fix for this issue next week. You shouldn’t have to uninstall/remove the Paperpile extension (this may delete unsaved files). Instead, you can disable and re-enable the extension:

  1. In the Chrome menu, go to Extensions > Manage Extensions
  2. Toggle the Paperpile extension switch off
  3. Refresh the new web app and click “Skip for now” when prompted to install the extension
  4. Wait for your library to load and then re-enable the extension.
1 Like

Thanks @suzanne. Yes I will keep this in mind next time it plays up. I was a little worried after I am unable access my library but next time I know I have a few options such as disabling the plugin and use Safari temporarily. Thanks :pray:

I have the same issue. What do you mean by “Refresh the new web app and click “Skip for now” when prompted to install the extension”? What is the “new web app”?

@Xiao_Lei When you disable the extension, this should stop the “Setting up your library” screen. Then you can refresh the webpage, this should show your library in the new Paperpile, and you should be prompted to re-enable the extension. Then click “Skip for now” and allow your library to load and sync without it.

I, too, am getting a lot of random glitches with my library.

Labels, references, search consistency seems to be unusually inconsistent of late

@ajn @zhao.paperpile @Xiao_Lei We released an update for the new Paperpile application and the extension. It should fix the issues with the start-up. If you encounter any more issues please write to


Thanks. I removed the paperpile Chrome plugin and app in the Mac application folder. I think I may just need to download the newest version and reinstall the application and web plugin.

Hi Sasa, thanks for chiming in.
Unfortunately, it hasn’t (per the screenshot).
I’ll write to your team and see what can be done.

1 Like

Hi @ajn this looks like a different thing, and from the screenshot I think we have this issue already in process of fixing. Could you please send the details on the support mailbox, just to confirm it. A short screen recording of the issue would be beneficial in this case if possible.
Thank you for your understanding.

Shall do ASAP.
In the interim, congrats on rolling out the new Paperpile.
PS Just a heads-up that I’m experiencing a significant degree of instability (numerous crashes and hangs) while synchronising between browsers (Edge and Chrome).

1 Like