Papers not in folders after import from Mendeley

I was able to import my library successfully from Mendeley using the import wizard, and paperpile shows all 1700 of my papers. My Mendeley folder structure was also preserved in the transfer.
However, nearly all of the folders are empty, and all but six of the 1700 papers are all un-filed and just in my “All Papers” section rather than in the folder structure I imported.
I’ve deleted the import and re-imported it to try to bypass this issue and still have the problem.
What am I missing?

Welcome to our forum, Katherine, and thanks for trying Paperpile! Is this still the case? Have you tried restarting the browser, perhaps signing out/in of both Paperpile and Mendeley? Deleting Chrome’s cache before re-attempting the import would also be worth a shot – some users who have faced the same issue have reported succeeding after 3-4 attempts. If you’re signed in to more than one Google account on Chrome, I would also suggest trying from a fresh Chrome Profile where you’re only signed in to your Paperpile-associated email.

It worked! I cleared the cache and signed in/out of both Paperpile and Mendeley, and deleted the folders and papers that I had imported during previous attempts to sync. Thank you so much Vicente.