PDF annotations private beta 2


#21

First of all, great work!

In google-chrome-stable on Linux, I tried to highlight and then underline. It seems the underline erased the highlight. But when I load the pdf in paperpile, both were present (which is what I want).

In google-chrome-beta on Linux, the connection to google-drive does not work.

In both -stable and -beta, if a pdf has been viewed from paperpile, then annotated in metapdf, annotation will not show in paperpile. I was not able to find a refresh pdf function in paperpile.


#22

Thanks for testing!

The automatic re-syncing back to Paperpile is not part of the current beta. You can trigger a re-sync though by starring or unstarring a paper. That will re-download the file from Google drive to the local cache if it has changed.

If you say “connection to google-drive” does not work. Does this mean if you click ‘Open from Drive’ the open dialog does not show?

If that’s the case can you click ‘F12’ and send us the output of the debug console.

I have not been able to reproduce (I tried with beta and stable).


#23

Hello Andreas,

I am having the same problem of orschiro. I´ll send the pdf for you.

Btw, congratulations for this great app.


#24

I just tried google-chrome-beta on my office computer and the “Connect to drive” function works. I think I have the same setup at home but I’ll check again when I get back.

It is good to know the star and unstart trick.

Thanks!

Hao


#25

LInux chrome Version 41.0.2272.64 beta (64-bit)

After clicking "
Error message:

There was an error!
The API developer key is invalid.
GET https://app.metapdf.com/resources/css/app.css.map 404 (Not Found)
app.min.js?v=24:1033 Loaded Google Picker API
rpc.js?c=1&container=onepick:449 Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘https://docs.google.com’) does not match the recipient window’s origin (‘https://app.metapdf.com’).
picker?protocol=gadgets&origin=https%3A%2F%2Fapp.metapdf.com&navHidden=true&multiselectEnabled=true…:3 Uncaught ReferenceError: init is not defined
clobbercookie.js:19 clobbering cookies for
Location {replace: function, assign: function, ancestorOrigins: DOMStringList, origin: “https://docs.google.com”, hash: “”…}
.


#26

Opening New File

When opening a new file, shouldn’t I be able to open a file that I just downloaded by dragging that file from the “download bar” at the bottom of Google Chrome to the “DRAG FILE HERE” box in metapdf? Doesn’t seem to work.


#27

Thanks. Do you have the PrivacyBadger or any other Adblocker or Privacy extension installed? If so, can you try disabling them and see if it solves the problem?


#28

Thanks, that should work. We are looking into it.


#29

Disabling the Privacy extension solved the problem. Thanks!


#30

Yeah, I’ve tried a couple of times since with different files. None of them work.


#31

I meant it should work eventually. We still need to investigate why it does not at the moment.


#32

It’s not immediately obvious how to turn highlighting off so that I can simply copy text. The most logical thing I could find was to click on the triangle portion of the highlight button at the top, and then click on the color that was selected to turn it off. This, of course, didn’t work. It didn’t occur to me for quite a while to click on the pencil icon itself. Perhaps there is a way to make that more apparent to users?


#33

Good point. We actually had at some point a “off” entry in the menu which would make it obvious. We probably just put this back in.


#34

Weird lines in between selected text:
http://imagizer.imageshack.us/a/img538/4940/NvP4M0.jp-g

Also selecting the text creates wide-pdf text selection (that’s a different PDF, but it happens across all of them):
http://imagizer.imageshack.us/a/img673/5747/kLoEhs.gi-f

It doesn’t let me to add pictures to the post, so just remove the dash at the end of the link


#35

Also each time I annotate, the previous annotation changes to a draker color:
http://imageshack.com/a/img538/8113/Qhf6Qi.gi-f


#36

@Moshe1010

Could you send the PDF where the annotations change to a draker color to andreas@paperpile.com? That would help a lot in debugging.


#37

I’ve sent you the papers
Edit: this forum has a bug? I currently edited this message with 4 numbers, only 2 apper (try to edit this message and you’ll see 4 different items listed)

Few more suggestions/problems:

  1. Be able to hide notes inside text. If I have a paragraph with 15 notes, the bubbles on the right side are overwhelming. If there are too many of them. it creates a white (new) page after the commented page, which is not useful.

  2. Mac’s trackpad (rMBP mid-2012) is too sensitive in terms of zooming in/out the paper (by pinching)

  3. The papers I sent you also have problems with strikethrough and underline

  4. Annotating/commenting next to a floating picture (side of a text), destroys the picture


#38

Same happens with a new post, is there a max allowed characters per post?
4. Annotating/commenting next to a floating picture (side of a text), destroys the picture
5. Scrolling isn’t smooth when there are pictures in proceeding pages - at least not in Chrome for Mac. Preview/Chrom’s PDF reader is much smoother than metaPDF (not critical, but it can create an issue when there are zillion images on proceeding pages and the PDF is pretty heavy because of that.
6. Zooming in/out creates a disturbance on the font:


#39

@Moshe1010

Thanks for reporting these issues. I have not been able to reproduce them on my computer. Do you see some of these issues also when you use the regular PDF.js viewer?

http://mozilla.github.io/pdf.js/web/viewer.html


#40

There can be 32000 characters per post. Not sure why you have trouble posting. Settings are complex for this forum. I’m still learning.

As for the bugs. Andreas will have a look at it. More generally, it’s important that metapdf can never be as fast as a “native” PDF reader like the Chrome reader or Mac Preview. MetaPDF is based on pdf.js which is the default viewer in Firefox. So it inherits all the limitations. However, it’s an active project and will become more stable and faster with time.