"Something went wrong while formatting your document."

I have a moderate document (the text with references has just about 12 pages), in the final stages of editing. 162 references. After I changed the citation style, I started getting this error: “Whoops — something went wrong while formatting your document.”

I tried reloading the document, restarting the extension, opening the document in “incognito” mode - always the same error. In the incognito, it did reformat the references, but still gave me the error, and I don’t know how to interpret it (could it be that they are not messed up in some way?).

This does not help with the trust in the platform. I have to finalize the document today, and have really no time to debug this. Disappointing.

Can you please think about some error messages and logs better than “Whoops” to troubleshoot problems with the product? There must be something more detailed. There is nothing worse than “Whoops” when you are working towards a fixed deadline.

I’m sorry for that. That’s clearly not the experience we want our users to have. Unfortunately there are many moving parts and points of failure.

We try to communicate know errors to the users wherever possible but there are also a series unexpected errors, which we only can react to with a generic error message. I can see that the “whoops” is particularly frustrating in such a situation…

However, if we knew what the problem was and how to fix it we would do this behind the scene rather than showing an error message.

Such errors, are relatively rare given the thousands of documents formatted every day, but if it happens it’s problematic. How do we address that?

Our support team has a median response time of 4-6 hours and we try to fix things for our customers if things break. We have technical logs on our side which helps with that. If that did not work in your case we clearly must get better with that.

Of course we also try to address the underlying issues if we can come up with a fix to avoid errors in the future.

@stefan thanks for the followup.

When the issue was happening, I had a prompt on the top of the screen to “report to Paperpile”. I clicked that link several times. It’s clearly been more than 4-6 hours since then. Should I still expect some response from the support team? Or was I supposed to use some other means to report that problem?

I understand the difficulties, but I don’t get any impression that the issue I reported was received/acknowledged by Paperpile, or that anything was done at all to investigate and prevent it from happening in the future. To me, this is a concern.

I had the same issue, with a moderate number of references. Tried all the things you listed, but it did not fix the problem.

Finally, using the addon (extension) sidebar helped. Specifically, following add-ons > paperpile > mange citations > update citations and bib worked.

1 Like

Ok that’s a fair point. The “report button” does not trigger a support ticket and we review them in batches to spot trends, and it’s not real-time. We have not changed it in a while and it’s there before we changed to our current support system.

I guess we should fix that to manage expectations better.

1 Like

@stefan I am again getting this error.

What should I do?

From @andreas:

That might be an intermittent issue with the Google servers. You can try to format your citations via our Google Docs Addon: https://chrome.google.com/webstore/detail/paperpile/imanmdcibgaflfaibbcmmkifdgllfopm?hl=en

It uses a different way to access the data, and it usually works if the other one fails.

Formatting citations did work via the addon (menu Add-on > Paperpile > Manage citations < Update citations & bibliography) (at least it didn’t report any errors), while the other approach (Paperpile > Format citations) is still generating that error message I mentioned above.

Thanks for posting this.

We still have not found a solution to that one. For some reason Google imposes different quotas for resources add-ons can use depending on how the user is signed in. We hope to remove the root cause that in neither case users get throttled by Google resulting in an error.

Thanks for posting this! Just ran into the same problem and the add-on worked for me also…!

a life saver.

1 Like

I am having the same problem but the Addon is not working either. I think I have worked out why: I am in edit suggestion mode. When I ran the PaperPile browser plug-in on a different chapter in normal mode it worked fine – or so it seemed: I did not detect any changes made to the in-text citations or the bibliography references at the end of the document!

Am very confused. This is my first time using PaperPile and it seems completely useless.

This is happening to me as well and is frankly maddening. I cannot load the add-on or format citations in any browser I’ve tried. I’ve also tried accepting all suggestions in the document and this does not fix the issue. This has been a problem for the past few days and I’m very worried as I’m on a deadline for the current project…

Do you have citations in a footnote? I had that error happening when I had a citation in a footnote. Removing the citation from the footnote fixed the issue for me.

For those who cannot load the add-on: There is currently a Google bug which is preventing us from working on some documents with suggested edits/comments. We have notified Google and they are working on a fix. Unfortunately, all we can do at the moment is to ask our users to make copies of their documents without any suggestions/comments.


We are unable to reformat citations while in “Edit” mode. Please advice if this is the same bug, and how we should troubleshoot it.