Unexpected errors in bibliography/reference with a "by."

Hi there,

I had an unexpected error in bibliography/reference after adding citations. The bibliography is added automatically and previously it worked fine. But recently I found that the reference was automatically formated as the following: “last name, first name, by., year…” Does anyone know why the “by.” is automatically added? It is weird. I tried to change citation style but the “by.” is always there. Thank you very much.


Welcome to our forum, @beny! We need more details in order to assist – are you working in GDocs or MS Word? Is this happening with a specific citation, multiple, or all? Which citation style are you using?

If it’s happening with a specific reference, perhaps editing its metadata would do the trick. Selecting the item in your library and hitting Shift-E or clicking Edit will open the edit dialog. Otherwise, feel free to share the reference so we can try to reproduce (select the item, hit Shift-S or Get Link, paste the resulting URL here or via chat/email [support@paperpile.com]).

Hi vicente,

Thank you very much for the reply. I am using MS Word and Paperpile plugin. It is happening to all papers when I use the Journal of Finance citation style (See the attached screenshot for reference).

link of the reference: The Real Effects of Financial Markets | Annual Reviews



Thanks for the revert and details. I can confirm this issue happens on our end as well, both on MS Word and Google Docs, which suggests there might be an issue in our processing of the style code (which we get from online repository CSL).

The only workaround to suggest for now would be finding an alternative style with the same characteristics, for which you can browse CSL. Waiting to hear back from the team for further insight / potential solutions – will keep you posted.

Great! Thank you very much.