Android annotations disappear on Samsung tablet

When I make a text annotation in the android client, it often disappears the next time I open the .pdf.

I’ve tried a few experiments to see what conditions cause this, but have not been able to find anything consistent yet
(tried: black-on-white vs white-on-black view mode,
close viewer and move back to main menu before exiting,
on wifi vs not)

This is using the Paperpile client from 13-jan-21 as well as previous versions from last year, on Android9 (Samsung s5 tablet).

1 Like

I’ve just opened up the latest version of Paperpile for Android (updated 28-Feb-2021) to discover that the annotations I made on the last PDF I read a few days ago are, once again, missing. This seems to happen frequently. I’m using a Samsung Tab 5SE.

I’ve down a bit of troubleshooting and tried some of the options @paperbrain mentions, but I haven’t been able to pin down a consistent cause. So, I’m simply flagging that I also continue to experience this issue.

1 Like

I wonder if it would be possible to add an option to simply open the pdf in a different app such as Xodo in order to do annotations. The paperpile app is good for reading, but I really want to be able to annotate, it’s an important part of a research workflow I believe.

In fact i tried this, located (with a bit of difficulty) the pdf on disk (it has a hashed not-recognizable name),
opened in Xodo, annotated. The paperpile android app did not see the changes, maybe because it was not looking for unexpected changes from another program. But could it?

Thanks for the feedback, @paperbrain and @joel. Strange - we’ve had reports of misaligned highlights and the like, but none of annotations not being saved. Does it happen in many different documents? I’ve let the team know; any further details would be helpful.

I haven’t noticed a consistent pattern yet (e.g., if the changes aren’t saved in documents where the highlighting is misaligned), but it happens about one out of every three documents I try to annotate. It’s enough to be disruptive.

Like @paperbrain, I’d like to see an easier way to open pdfs in other apps like Xodo for reading/annotation, and then make sure that these annotations are synched back to Paperpile.

This happens to me too and is honestly quite annoying. I had read quite a few pages on my tablet (Samsung Tab S7) and I’ll have to start again now…
It had also happened before to me, I tought it was because the tablet had gone in standby with the pdf open, but with this last document I had been super careful about closing the app.

Also, I strongly support having the opportunity to use a different editor for annotation and then sync them back.

1 Like

I tried the new March 16 not-beta release, hoping this problem would be fixed.
It might be better, but there is still something weird.

Right now I have this repeating behaviour.

  1. highlighted some text
  2. switch to the tablet “desktop”, the center button on the Samsung tablet.
  3. re-open Paperpile
  4. re-open the paper: highlights are missing
  5. go back to the “all papers” list
  6. re-open the paper, highlights are visible
  7. go back to step 2

I have done this 5-6 times in a row, it seems reliable.

Please fix this or allow us to use a different viewer for annotation.
I really like Paperpile and want to use it!

@paperbrain, the latest release of the app did indeed include significant backend fixes for highlighting/annotating issues like this one; I trust the experience has improved since then? I’ve notified the team about this last behavior you report, will let you know of any updates on the matter.

How about for @Ludovica_Pannitto and @joel, have you continued experiencing missing highlights/annotations? Please let us know.

I haven’t experienced my reported issue so far following the latest update, which is promising! I will provide more information if it returns – but so far, so good.

Thank you!

1 Like

The repeating disappear-reappear behaviour I mentioned in my last message above is using the March16 update v1.2.3, which is the newest version as far as I know.

I have tried out the Ipad version of paperpile and do not find any issue with annotations disappearing in that version.

However for a small particular reason I prefer to use the android (basically, using Ios would mean I would need to cary around two different tablets)

I did some more testing, this time watching the files in Google Drive also.

[ The description of the test refers to the android “back” (looks like <) button and “home” navigation buttons (looks like a rounded square).
After annotating, the back button returns from the pdf to the paperpile entry for that paper (the one with biblio info for that paper), whereas the “home” button goes to the main android “desktop” screen. ]

It seems like one fairly reliable way to cause the missing annotations is to click the android “home” button after creating an annotation (rather than clicking the back button). Then on the desktop, after clicking paperpile and re-opening the pdf, all annotations are missing, both previous ones and the most recently made one.

However, on Google drive what I see is that all the previously made annotations do exist, and only the most recent one (the one followed by the home-button click) is missing. So the problem is both that it is not saving annotations sometimes, but also in some other cases it does not display annotations that exist on drive.

After exiting and reentering Paperpile some random number of times the previous annotations reappear, but the most recent one (which was followed by the ‘home’ click) is permanently gone.

I tested the android app on a pixel slate chromebook (chromebooks can run android apps), and had no problem, was not able to produce the disappearing annotations.

They problem is somewhat random so this is not a definitive test, but it makes me wonder: is the problem specific to samsung tablets? All the people who have mentioned a tablet type (including a comment in the play store) have said Samsung.

Has anyone who uses a not-samsung android tablet had the disappearing annotations problem?

Thanks for the thorough and accurate feedback, @paperbrain. Indeed, the team also noticed this is so far isolated to Samsung tablets. We haven’t managed to reproduce consistently but it’s on our radar - the apps are still being closely monitored after their official release.

I can report the same problems (highlights and annotations disappear) on my Samsung Galaxy S6lite tablet with the latest version of the Paperpile app.

It seems that annotations/highlights go missing instantly if I hit the back or home button of the tablet. The longer I do “something” in the app (view other pages, view many pages in gitter view etc.) the less likely are the annotations and highlights gone.

1 Like

( @ philipp same here, the longer I stay in the app, the less likely that annotations disappear).

I updated the tablet to Android11, and the problem seems better. It is hard to be sure, because it’s random.

Now I have the impression that: the annotation are always saved, just not visible sometimes, and just re-opening the particular pdf usually makes them reappear (or disappear sometimes!)
I also left the same pdf opened in the web version of paperpile, and saw the annotations being added almost immediately.

One thing I find odd is that there is a folder Internal Memory > paperpile that contains the pdfs on the tablet, and the annotations are never present in these. It makes me wonder if the annotations are saved separately in the database and just dynamically placed over the page image… but that would seem to mean that it is always keeping a separate “clean” version of the pdf, as well as the version saved on Google Drive that does include the annotations.

Anyway, it cautiously seems better

For an update, I’m continuing to lose annotations. It’s sporadic, but it seems to happen under the conditions that @philipp describes here when using my Samsung Tab 5SE.

There are many aspects of the Paperpile Android app that work well, and I’m grateful for it. However, I’d really prefer to use another reader/editor, as I’m finding that the built-in reader has trouble handling PDFs that other readers (e.g., Xodo) seem to handle easily.

I am still having this problem as well.

Here is a video of it happening: Upload files for free - 1small.mov - ufile.io
In this case it shows an existing annotation, go to the search menu, re-open the pdf, the annotation is gone.

I have also tried other android tablets: a chromebook (not an android tablet, but I installed the android app), and an Onyx ebook reader. On these the problem -seems- to happen much less, but annotations still disappear (and sometimes reappear).

Unfortunately I believe that Samsung is the most popular brand of android tablets.

Very frustrating, it basically means annotations are not available. In my case I like to add margin notes with some details after I figure some part of a paper, this takes a bit of time to type in, and it’s horrible to lose it. It would be kinder to people’s time to just disable the feature until it works.

This is not meant to criticize Paperpile overall, I really like every other aspect of paperpile.

1 Like

Thanks for the extra input and the clear videos, @paperbrain - that’s been useful for the team, although to date we haven’t managed to reproduce the issue consistently. Our QA is looking into getting an emulator to keep trying.

I’m afraid this means I still don’t have any advice/improvements to share, but we will try to prioritize a solution for the matter. Your patience and help troubleshooting this so far are much appreciated!

A follow-up to report that I’ve just encountered this problem once again (I’m using the latest version of Paperpile on Android). I’ve now lost several hours of annotations, which is frustrating. I’m now at the point where I can’t trust Paperpile on Android to consistently save my annotations, so I’m having to use a clunky workaround (i.e., syncing my PDFs via a different app; annotating them in XODO; re-uploading them to Paperpile).

Please consider allowing users to use a different app to read/annotate until this is sorted. I’ve lost quite a few hours of work to this issue.