[bug] Highlighting doesn't highlight what I select

this is a bug that unfortunately has persisted for years within paperpile, and will likely not be fixed! When ive emailed them about it support always seems surprised, though I imagine that a lot of people contact them with this issue.

ha i noticed Ive already replied on this thread. Its just so frustrating to me!

Thank you for bumping this thread @Alison_Hall. I’ve brought this issue again to the team’s attention but we are still having trouble reproducing on our end. We’d like to fix it but we won’t be able to if we can’t identify the cause. If anybody on this thread would like to share additional information, please do so here or contact us via the in-app chat or email support@paperpile.com.

Hi @Alison_Hall , @ankoman @Sota_Hirokawa !
We are currently trying to reproduce the issue and get to the bottom of it. It would be much appreciated if we would get some additional info from you:

  • For start it would be nice to have informations about the affected device’s pixel ratio and resolution. You can easily get this info by visiting this link https://www.mydevice.io/
  • The affected PDFs, are they uploaded on Windows, MacOS, or using our mobile app?
  • What zoom levels are you using (the meta PDF zoom using the zoom buttons, and the Chrome zoom level)?

Thank you for your understanding, and looking forward to your replies.

Hi sasa, thanks for working on this problem.
Here is the info of my environment:

  1. Device’s pixel ratio is 1440 x 900 px, and resolution is 192.00 dpi
  2. I uploaded my PDFs from MacOS, using chrome extension
  3. On every zoom level, the highlight position shift 1 row

Also, I’ve found that the highlight works well while I search words using “command+F”.

1 Like

@suzanne Here’s another example of said bug.

From this screenshot, we can see that the selected text on the left doesn’t match the highlighted section

Using preview from Google Drive, I can select and highlight the intended selected text. I couldn’t remove what paperpile highlighted, see the text with darker color.

Here’s the link to the used pdf. Paperpile

The text is on the 2nd page, towards the bottom.

Thank you for the screenshots, @Emrick, but I can’t access the PDF from the link you shared. Can you share information about your device that @sasa requested with us?

@suzanne Try this link for the PDF. Or you can search “Shannon sampling II: Connections to learning theory” on Google Scholar. It should be the same PDF.

For the screen metric, here’s a screenshot:

The PDF is uploaded on Windows, by clicking the paperpile button on Google Scholar.
The browser zoom level is 100%, the issue persists, to different zoom levels in paperpile.

1 Like

For me, zooming out solved the problem. Zooming out, highlighting, and zooming in worked. Only tested in two papers, though.

1 Like

The zooming out and zooming in approach worked for me as well. Zoom out - highlight works as expected, then you can zoom in again to read.

This is obviously a notable flaw in the product, and it doesn’t bode well that it remains an outstanding issue for years. It would be ideal for users to provide more info so the team can reproduce the problem, but of course these are the moments when users decide maybe they’re better off using another product. So the onus for being able to reproduce the problem isn’t on the users here.

Chrome version: Version 126.0.6478.127 (Official Build) (arm64)

Paperpile version: Version 1.5.698

Macbook Pro 13 inchi M1 2020

OS: Sonoma 14.5

Summary

I recently started having this same off-by-one highlighting issue after I switched to the new Paperpile Beta and only happens when using Chrome on Linux (both Ubuntu and Fedora); I do not have any issues on Windows whether using the old or beta app. There is also no issue when using the old app to read papers on Linux Chrome. So, while this issue may have multiple origins, the manifestation of this highlighting issue seems to be clear in my situation and may lend insight into the causes of other situations.


Assessment of problem

The problem here is that the scroll bar for the PDF reader does not scroll through the pages in the PDF document but rather PDF reader app/frame. (This is obviously a problem in and of itself, because scrolling through the document is only possible using the mouse scrollwheel, arrow keys, or PgUp/PgDn, which can be a PITA for docs with many pages.)

Scroll bar up

When the scroll bar is all the way up, you can see the toolbar at the top and highlighting works as expected:

Selection:

Result:

Scroll bar down

However, when the scroll bar is all the way down, the toolbar is no longer visible and highlighting text with the cursor causes the highlight to appear about 1-2 lines up:

Selection:

Result:

Hope this helps. Happy to provide more information, too.


Specs on Ubuntu system

Chrome version: Version 126.0.6478.126 (Official Build) (64-bit)

Paperpile version: ?

OS: Ubuntu 20.04.6 LTS (64-bit)

GNOME Version: 3.36.8

1 Like

Thanks for chiming in @PeterJ, and @sseyler for the detailed report — it is much appreciated. It’s true we haven’t been able to prioritize this or other pending fixes for the PDF viewer in quite a bit; unfortunately this slowness is a reality we assume as a small, self-funded team.

That being said, once the new web app is fully implemented and running smoothly, the PDF viewer is one of the topics we intend to prioritize for updates and nuisances we’ve long been aware of (the team is actually already looking into potential fixes for these highlighting inconsistencies). So there should be news on this front later in the year.

1 Like