Two suggestions on keyboard shortcut for "insert citation"


#1

Thanks for all your great work on developing Paperpile. I switched over a few weeks ago and haven’t looked back.

I have two quick suggestions about the Ctrl+Alt+P shortcut to insert a citation in Google Docs:

(1) When using the US international keyboard in Windows, this key combination also happens to be the shortcut to insert the character “ö”. This means that every time I create a citation with Paperpile, I also get an “ö” that I have to delete manually. That’s not a big deal, but a bit of an annoyance. I wonder if there is some way to suppress the insertion of that character in Google Docs when Paperpile is claiming that keyboard shortcut?

(2) Most of the time when creating citations I am entering the author’s name in the body of the text, so I use the “suppress author” option. Would it be possible to define an additional keyboard shortcut, to insert a citation with “suppress author” already selected? Failing that, having the tab stop on the reference when inserting a citation, so as to be able to open the advanced options menu from the keyboard (suggested here Shortcut for page numbering ) would be a good way forward. Otherwise creating a citation with “suppress author” requires a few mouse clicks. Doing everything from the keyboard is much quicker and easier.

Thanks very much!


#2

We’ve collected some feedback along those lines already in particular how to improve citations of the form Doe et al (2001). Adding a more efficient way without the mouse would clearly be an improvement.

The “ö” puzzles me. We’ve never seen this for ourselves nor did anyone in two years report that. I wonder if this keybinding comes from Windows or Google Docs or elsewhere on your system.

@jason can you have a look at this on your windows machine? I could not reproduce so far.


#3

Thanks for your quick response, Stefan. Ctrl+Alt+P is the normal keyboard shortcut for “ö” when using the US International keyboard in Windows. There is a description here: https://en.wikipedia.org/wiki/QWERTY#US-International I was hoping there might be some way to suppress the output of the ö character when that shortcut is claimed by Paperpile.


#4

Thanks for clarifying. I did not realize you were talking about US international not just US keyboard. We all use US keyboards so it would have been strange that we missed this problem so far.

I’m afraid that’s handled deep inside the operating system and can’t be controlled by Paperpile. Actually, it’s not just a problem with Paperpile’s shortcut it’s the same with many other Google Docs shortcuts that use Ctrl-Alt. Windows treats Ctrl-Alt as AltGr which activates the special characters. There is no way to turn this off. Here are a few workarounds:


#5

Thanks, this is really useful. I had not realised that there are other Ctrl+Alt shortcuts in Google Docs, and I now see that most of them do not work at all in combination with the US International keyboard. Your link is very helpful: as suggested there, I’m now using the Microsoft Keyboard Layout Creator to remove most of the Ctrl+Alt shortcuts from my keyboard layout, so that they don’t interfere with the shortcuts in Google Docs.


#6

Hi Rob

Thank you for making us aware of this. I have another suggestion. As someone who frequently writes in different languages I have more than one keyboard installed on my system and switch between them on the fly using "winkey + space ". You may find it useful to switch to a standard US keyboard before adding references, and switching back after. Alternately, you could just switch to a standard US keyboard while writing if you are not using the special characters.

You can add additional keyboards via Control Panel --> Clock, Language, and Region --> Language. There should be a box which says English (United States) you can add a standard keyboard by clicking “options”.




#7

Hi Jason, thanks for following up. In fact using the Microsoft Keyboard Layout Creator is perfect for me: I’ve now created my own keyboard layout that includes only the shortcuts I need (basically just the dead keys) and not the ones I don’t. So that problem is solved, thanks!