Use Apple Pencil only for highlighting

I am starting to use the iOS app on my iPad Pro. I would like to use my Apple Pencil to highlight the text but I noticed that it highlights text even if I use my fingers. Is there a way to use only one of the two options so that I can use the other to move around? Thanks.

Thanks for the query, @Lorenzo_Fabbri. There’s currently no setting on our mobile app to distinguish between an Apple Pencil (or any stylus) and fingers. I take it you’ve used this feature in other services? Let me know and I’ll add the idea to our tracker.

Yes, for instance in PDF Expert. For me it is unusable otherwise.

1 Like

@Lorenzo_Fabbri I was wrong! If you have the Apple Pencil, the option to use it for highlighting / annotating should appear in the menu like so:

Let us know if it doesn’t appear for you.

1 Like

It does not!

That’s strange, @Lorenzo_Fabbri - it doesn’t appear for me either, but that’s likely because I don’t have an Apple Pencil. The dev team doesn’t have any suggestions yet but they’re looking into it. In the meantime, could you try toggling pencil settings on your device and refreshing the app to see if anything changes? Let me know.

I even restarted the device but nothing… @vicente

I have the same problem. The button used to be there but it disappeared. Restart didn’t help either.

Any update on the problem @vicente? Thanks.

Thanks for the report @FabianS and the follow-up @Lorenzo_Fabbri. The team has so far been unable to determine what may be causing this option not to appear. Our mobile dev will take another look soon and let us know - I’ll update you here.

2 Likes

@vicente @Lorenzo_Fabbri @FabianS weird that it is not working for you guys.

I just tested on mine, it seems to be working fine. I have iPad gen 6 OS 14.2.

It’s weird. I tried it again and now it’s back. So everything works for me.

Same here. The button “Use Apple Pencil for Annotating” was there and worked fine. It suddenly disappeared. Now, fingers annotate - terrible :-(.

Please, tell me how you got that button back!!

2 Likes

@vicente In the meanwhile, is it possible to open the PDFs from the iOS app with another PDF editor (e.g., right click and “Open with”)? Thanks.

Actually like the others the pencil only option suddenly disappeared for me too.

Restarted, toggled Apple Pencil from the settings, tried multiple documents… nothing seems to be able to restore. The only thing I haven’t tried is completely removing and reinstalling - but the app is not going to remember already downloaded papers so that’ll be pain in the ass.

Not directly from the list but once you open the pdf you can use the upload button to do open with.

Also, probably a good idea to not mix topics in this thread about Apple Pencil.

And it’s randomly back again

Thanks all for your patience. It seems the pencil-only highlighting option appears once the viewer is open and one actually uses the Apple Pencil for annotating. In this short video our apps dev selected the pencil tool, drew a line with his finger, then the second one with the Apple Pencil and the option appears. If this doesn’t work for any of you, please let us know!

1 Like

Okay I can see it now. Is this a bug or a feature? Thanks!

Great! It’s a feature, but we’ll consider changing it up for clarity in light of this thread.

2 Likes