You cannot view or change the references of this document

I have same issue!!! Still! its May 2020! Reloaded, restarted, updated and still clicking on the link I put in my comment in GoogleDoc in the paper takes me to “cannot view”!!! How am I supposed to retrieve any of my citations? Please help.

Same issue here! Can’t believe it’s 2020 and there seems to be no working reference manager for Google Docs! (Tried Zotero before Paperpile, and it was so slow as to be unuseable).

Not sure what happened, but it seems to work now! :slight_smile:

New to Paperpile and I am having this issue. Any updates?

I love paperpile citation management. But not having links that point to the citation at the end of the document, makes paperpile completely useless. To me, the current usecase and behavior is just the opposite of what a citation manager should be doing. So it’s not even a bug, it simply makes Paperpile the wrong product.

Please fix that asap so Paperpile becomes the great product it should be.
… and now I have to do all my citations again manually ;-(

@mikeseven, I understand the expectation for citation links to point to the reference information. As I explained to @Thomas_Brewer on this separate thread, it is possible to go to the item on your library from the citation options. The links are currently internal and not meant to lead anywhere, but we’ve gotten this request before so will be considering alternatives moving forward. I’ve added your +1 to the topic on our internal tracker.

I also had this problem. The solution for me was to click on the placeholder, and then invoke “Paperpile > Insert citation” (CMD + SHIFT + P in macOS). This opens the dialog that allows to see and edit citations (shown here Repost: You cannot view or change the references of this document - #2 by vicente)

Without invoking the command I could not see the dialog, probably it’s a bug.

Welcome to our forum, @LucaMarconato! That does sound like it could be a bug, but also potential interference from other extensions/plug-ins. Could you try turning off all browser extensions, then only Paperpile back on, refreshing and giving it a go? Do you have any third-party add-ons installed in GDocs? Let us know.

Thanks for your answer. Indeed it worked! I have 15-20 extensions, so it took some trial and errors with a “binary search” to investigate, but I think I found the reason. If I disable the “Zotero Connector” extension and I do “Force Reload This Page”, clicking on the link shows “Paperpile Citation”, if I reenable it and then to a force reload again, Paperpile will show the url instead.

I will disable the Zotero extension, and if I need them both (sometimes I need them) I will use the CMD + SHIFT + P workaround.

One note, in macOS and Chrome to do a full reload one usually presses Shift + Cmd + R, but in this case this is mapped to “indent right” in GDoc, so to trigger it one needs to do the following: click on the “View” menu, press Shift, then click on the “Force Reload This Page” entry, that will have appeared.