You cannot view or change the references of this document

I created a Google Doc. I added references with the Paperpile plugin. I am logged in to the Paperpile app. I am logged in to Google.

I exported the doc as a Word file.

Now I click on one of the references in the Word file, and I see this:

You cannot view or change
the references of this document

You need access to the Google Docs Document and open this page via the Paperpile Chrome extension or Google Docs add-on.

This is not expected behavior.

I expect to see the paper linked by the reference. I don’t know what Paperpile will show me (pdf? paperpile app? google doc? website of the paper?). But I do expect to see something, and instead I get an error message.

Question 1: How do I enable expected behavior?

Question 2: When I share this Word file with my coauthor, how can I enable the expected behavior for them, too?

2 Likes

Those links are essentially for internal use; they link to the metadata which we use to format the references and are how we enable reference management in Windows. When accessed from within a Google Doc, they allow the user to view and edit the metadata in order to manage the references. However, when accessed from outside the document we block said access. We may update that page to show more relevant information, but at the moment we simply block it to prevent citation tampering by people whom you have shared a PDF or Word document with.

OK, I think I’m starting to understand the Paperpile developer’s perspective on this issue.

You might consider the user’s perspective.

The error message is uninformative for me and my coauthors. When my coauthor asked “Why am I getting this error?” I was not able to give any meaningful answer. Indeed, I was frustrated that I couldn’t even access my own references. This unexpected behavior convinced me to stop using Paperpile when I share Word documents with collaborators. In my network, Word is the software most people are comfortable with, so I need to accommodate.

Let me propose a new error message that might be informative for users:

Sorry, this link only works when accessed from a Google Doc with the Paperpile extension installed. It is not meant to be accessed anywhere else. Please contact the author of the document an ask them for access to the original Google Doc file. Then make sure you install the Paperpile extension. Finally, try clicking the link in the Google Doc.

If you’re interested, I’d be happy to give my criticism for any other message you’d like to propose to show users.

3 Likes

Hi, Jason. I recently paid for a 1 yr subscription to Paperpile. I am having the same issue as OP, but from within the google doc (of which I am the owner). I click on a citation that I’ve added, then I click on the paperpile citation link that pops up; when I follow the link I get an error page saying, “You cannot view or change the references of this document”. I have the Chrome extension installed and active.

How do I view info for the citations I added? Thanks!

Try restarting the extension by going to More tools --> Extensions, in the Chrome menu, then switch the Paperpile extension off, then on again, then reload your docs tab.

You should be seeing this when placing the cursor in a citation:
image

To open that reference in your library, click edit, then on the blue bubble, then on Open in Paperpile:
image

To view all references in the document, go to Paperpile --> View all References, in the Google Docs menu.

2 Likes

Thanks much, Jason. This worked in my case.

Hello,

I downloaded a .pdf of my document and posted it to an online pre-print server. When anyone clicks on a citation now it takes them to this error page. Is there any way to save a .pdf of the document such that these links are disabled altogether? (store in-text citations as plain text instead of links to broken webpage).

Thanks,
Matt

@Matthew_Olm Our sidebar add-on has the ability to export a copy of the document where all the references are replaced with plain text.

I have this problem even if clicking on the link from within GoogleDocs, with the add-on installed, and online.

When clicking on the link, I get:

image

If you are using the add-on you must go to Gear --> Manage references, to edit the metadata.

Thanks.

To be truth, I was not even trying to edit the metadata, I was just trying to see the reference, something that is not easy with the add-on. I need to find again the reference in the search field to be able to access its website. It would be nice if the website was available directly as one of the options when clicking on the reference.

Try restarting the extension by going to More tools --> Extensions, in the Chrome menu, then switch the Paperpile extension off, then on again, then reload your docs tab.

I followed the instructions above from @jason 's post, but this is what I see:


It doesn’t open a Paperpile bubble where I can open in Paperpile.

Is that feature gone?

2 Likes

This is happening to me too. This must be a bug… And it renders the whole Google-Doc integration close to useless.

Was there some recent change to this? The interface looks different now (as in picks above) and nearly all information available is useless (given that the link always returns an error, even when accessed by me from within my own doc using my own browser with the paperpile extension activated).

I have tried turning extension on/off, reinstalling the extension, logging off and back on my chrome. Still works as in the pictures above - no way of opening in Paperpile or even adding/removing citations in a multi-citation (!!). What is the fix to this?

2 Likes

I have the same issue. Working on a document that had no problems as recently as yesterday. When I click on an existing citation, I get the following:

Then when I click ‘edit link’, I get the following:

I cannot view the references or add/remove papers.

I tried switching off/on my chrome extension logging in and out of paperpile, etc…

Any advice?

1 Like

I have the same problem as @Meegs , everything worked well yesterday but today I have exactly the same problem - update which has caused a major bug?

We will release an update that will fix the issue. Seems like there was a Google Docs update being gradually rolled out.

Please follow this thread on updates on this:

https://forum.paperpile.com/t/cannot-edit-citations-in-docs/3906/7

We’ve updated the Chrome extension and this problem should be fixed as soon as you get version 1.5.95

Hello Paperpile Helpdesk,

I’ve been communicating with Vicente at Paperpile about this exact thing for weeks! Everything the posters above said has been happening to me. I have all the same questions-- essentially what do I do with these non-working links? All of my citations and references have a link which results in a frowning face and error message. This is not going over well with my readers and I need to do something to clean it up. I hate to do a select-all and clear all hyperlinks because there are useful ones mixed in, and hand-editing several hundred links is not appealing to me for obvious reasons.

I’m afraid I’m still stuck on this problem. If anyone has a solution, I’d love to know it!

PS, updating Chrome did not solve the issue. I also uninstalled and re-installed Paperpile; no change.