Android annotations disappear on Samsung tablet

Is there any progress on this issue?

As mentioned by others, occasionally I lose a lot of work from this bug.

It occurs to me that PP is only considering part of the academic writing process:
besides writing, there is a lot of reading to be done, both to learn the state of the art
in some small area, and then in writing the related work.

I do not use PP for writing at all, I only use it as a database to manage papers to read.
But the reading experience is quite bad.

As mentioned in a different post, the easy fix to both this and would address a number of other feature requests: just provide a quick way to re-import a .pdf on mobile. There is already a share button to export.
With this feature, we could share to whatever pdf viewer we want, make use of annotations, pen input, etc, then re-attach to paperpile.

No updates to share for this issue, unfortunately. What I mentioned in my last post is still the case – our resources continue to be focused towards the features posted on our roadmap, so improvements for the mobile apps are yet to be prioritized.

This means that although we’ve managed to reproduce this issue under some specific conditions, potential solutions will require time and resources we are currently unable to take away from those other projects. Barring further delays, we hope to have most of the big updates up and running by the end of this year, at which point the mobile apps will come back into focus. Sorry I don’t have workaround to offer in the meantime.

Hello,
this is just to confirm that on my Samsung tablet this bug happens incredibly often (if not always). Overall, this makes the annotation feature garbage on the tablet, which is unfortunate as I had bought it mostly to use it for reading and annotating in paperpile.

Still working on the go on my phone, where this bug has never shown up. Of course, the UX is not good on a small screen.

Looking forward to the work shift towards android apps!

1 Like

Also wanted to confirm that this is happening frequently - read three papers today and lost annotations on two. I had to go through and rehighlight because I wanted them saved.

It’s really disappointing because using paperpile actually converted me from being one of those people who could only read on actual paper to being able to read on a screen and I bougth a Samsung Tab S8 to use paperpile + an electronic lab notebook to “renovate” my workflow. Now my paperpile notes are disappearing on me :[

Same here on my Galaxy Tab S7+. Just ragequit my annual subscription for this. Very frustrating that even after over a year’s time this STILL has not been solved, while the team is focusing on upcoming features. I’ll renew my subscription if this issue is fixed.

We’re sorry that we cannot prioritize mobile at the moment, as the rewrite of the web app is our current priority. Once that is completed, mobile apps will come back into focus. As I mentioned earlier in the thread, this issue has proved difficult for the dev team to reproduce, and will require more work than our efforts can currently allocate. Again, we apologize for the inconvenience.

That worked for me. Thanks for sharing your solution!

1 Like

How about now? Is there a solution to this? It basically makes the Android app useless for me as keeping highlights is one of my primary use cases for the app.

2 Likes

Although this has unfortunately not yet been addressed, our new beta web-app serves as a workaround to access and annotate papers on mobile browsers.

I’m still having this issue on Android tablet.

How to access it from mobile browsers? When I navigate to app.paperpile.com I still see the notice to download the android app from the store.

After having signed up for and activated the beta, once you see that notice on your mobile browser, open settings and click Desktop site. Check out this quick video for reference.

I didn’t think of trying that. I can access the web app. It’s a bit tiny, but it is expectable. I will try it out! Thanks!
BTW, I am not supposed to work offline in this way, right?

Not yet, @ilpelle – offline mode is coming on the new web app but hasn’t been implemented in this version of the beta.

Hi @vicente, after a few weeks of work, I can share my current experience, should it be useful for you.

Using the web app from a tablet works good enough. Finding and adding papers is smooth. Editing metadata is not: the focus in the input fields is quite unstable, and if you type fast, the caret moves around or letters are duplicated. In general, the editing panel slows down the experience significantly.
You cannot use the automatic update of metadata, but that was expected as it’s based on the extension that you cannot install in off-the-shelf android chrome.
Adding comments to a paper is also ok: sometimes the textarea where to write comments randomly closes, but it’s manageable.

Reading PDFs works. Highlighting and writing text notes also works. Unfortunately, in the browser you don’t have any possibility to scribble, which is one of the most important ways I take notes on papers.

So, my overall workflow is currently the following:

  • I import a paper from the tablet’s browser, adding the pdf.
  • Fire up the android app. Read and scribble, using @paperbrain trick not to loose annotations. 1/3 of the times I yell because they actually get lost anyhow.
  • Get back to the android browser, open the pdf, use the “summary” feature to get all highlights, and write a summary in the comments.
  • Once I get in the office/home, I open up the browser, update the metadata, and add labels/folders.

As you can see, it’snot really a smooth workflow: you need 2 different apps and 2 different devices to get the work done. Also, the most important part (scribbling) is a work that is sometimes lost.

I really hope that we can get all this sorted very soon in the future!

Is there any progress or update on this?

I see the app was updated on 9 June, and it says "Various bug fixes and improvements.
Hoping maybe this is fixed.

I would just try it too see, but because the problem is “random” it takes some time to figure out if it is broken or not.

Apparently the update did not fix the issue, it has already happened to me multiple times :sob:

The recent mobile updates addressed small nuisances and general maintenance. We understand the gravity here for all affected users but unfortunately the scale of this issue requires time and resources we have not been able to spare. Once the new web app and extension are fully implemented, we will be able to address this and other important pending matters on mobile and other areas.

This is definitely still an issue! For the last few months when I finish annotating a paper, then I navigate to my library, open the document I was just annotating, and poof! No annotations. This happens when using my Samsung tablet and Samsung phone and also when using wifi and when using mobile data.

Still no fix for this, almost 3 years later?

Edit:
My work around: when I finish annotating a paper, I print it to PDF, annotations and all. That way when the annotations get deleted, I still have a version with them saved. Hopefully this continues to work.

Still an issue three years later with no fix in sight it seems.

I subscribed to Paperpile to be able to annotate PDFs on my tablet so there is no reason for me to keep this service anymore.