Cannot edit citations in docs

I reported it several times, but no one even responded to my messages

Where did you report it? Our support team answers every request that comes in via support@paperpile.com or the in-app messenger typically within a day (median response time is currently 9 hours).

I will follow up on that. It can happen that you replied to an older support thread that was already assigned to a developer who missed it.

See my post in this thread, dated 9/19. I also emailed you directly several times, the last one being 12/24/19, where I asked, “hi, is this something you guys will be working on, or should I give up asking about it? Thanks”

I answered in September 2019 here in the forum:

Again, I will follow up what happened to your other support requests.

My question from last September is still relevant: In the situation where you cannot edit a citation because you don’t see the “Paperpile citation” bubble, can you insert a new citation in the same session.

I did not get that was a reply to my post (there have been multiple posters in this thread). But yes, I can insert a new citation.

I followed up with @vicente and it seems in the past 6 months except you and @Deanne_DiPietro only 3 other people reported this issue. For 2 users it was just temporary and for the third one it turned out to be some sort of authorization issue. The user could easily solve it be re-authorizing Paperpile here:

https://paperpile.com/reauthorize

If that does not fix it, we have the following checklist:

  • Restart the extension (disable/enable)
  • Make sure you have not changed the settings of the Chrome extension in Chrome. “Site access” should be “On all sites”

  • To verify that you are signed in and the extension actually works can you try to import this paper (or any other): https://journals.plos.org/plosone/article?id=10.1371/journal.pone.0227177 via the “P” button
  • Check in your library if it ends up there correctly with the PDF. If that’s the case we know you are signed in correctly to the Chrome Extension.
  • Open a new Google Doc and check if the the “Paperpile” menu and “P” button show up. If so you should be able to insert a citation.
  • If you can insert a citation please hover over the newly added citation and check if the “Paperpile citation” button appears which should open the citation edit dialog.

ah, OK, that seems to work, thank you!!! BTW, it also seems to work in the Brave browser…

Awesome, I’m really happy that did the trick for you
:tada:

Thanks for telling me about the option to export without citation codes. That solves my problem by bypassing the issue and providing me a way to share my document without the confusing links in question.

As for the rest of the experience that I’ve reported-- I’ve tried a lot of different suggestions and still only see a bubble that has the link, not an editing bubble. I’ve figured out though that if I click Paperpile-> Add Citation I get the editing bubble. So I believe it is functioning as intended. I just think you’ve got me and some other users confused because 1) that link appears to have no function for the end-user, 2) the editing bubble doesn’t appear for some of us unless we go into the add-on, and 3) we expect to be able to create an end product (after we’re done editing, that is) in which the citations link to the references.

Anyway, I’m good now that I know how to clean out those links, and how to get the citation editing bubble to appear.

I recommend adding some help text about these things in your help documentation, and I wonder if you should consider trying to hide the misleading url that appears when you click on a citation. Or at least tell your users not to expect it to be useful to them.

Thanks for a great product; I’m still learning about it, obviously!
Deanne

Hi Stefan, I tried this on a different computer (PC running Win10 pro). I reauthorized, then deleted the extension and re-added it. I am still getting the same problem:

image

Hi @stefan, I’m also seeing this bug. (Chrome 80.0.3987.149, Mac OS 10.14.6, Paperpile extension 1.5.137) Reauthorized, restarted the extension, confirmed it has the necessary permissions, restarted Chrome. Ingesting papers to the library works correctly, inserting citations works correctly, editing existing citations gets me the standard Google Docs link edit bubble rather than the Paperpile parsing of them.

Does this happen for every document?

When you insert the citation does the problem occur in the same session? In other words: you insert the citation and then you can’t edit it right after?

Correct. For example:

Also confirming that it’s occurring both on my document in progress, and on that brand new one I just created.

OH HEY, if I place my cursor in the citation, I get the useless GDocs bubble, but if I open the paperpile “Insert Citation” (from the paperpile menu or from kb shortcut), I get the correct behavior. So it’s only an issue of not being able to override the default link mouseover behavior. That is workable, if ungraceful.

1 Like

Hey @stefan even I am facing the same issue.

I have cited using the Paperpiile addon in Google Docs.

Until this stage, it works perfectly fine. The problem starts when I export the doc to pdf or word to share with my co-author. If I open the pdf and hover my mouse to the in-text citation, I can click the in-text citation and it opens a page that looks like this

I have tried turning the extension Off and then turning it on again, but no luck. How will my co-author or any of the readers get to know the exact source? I believe previously when a person used to click on the citation, they used to be diverted towards the Paperpile website which showed the respective source.

Plz, let me know how do I fix this?

That’s weird. I have not seen this before. I only saw the case that the extension did not load at all for whatever reason. But it seems in your case the extension loads just the bubble does not get updated correctly. Do you see any Javascript errors? Open three dots menu in Chrome > More tools > developer tools; choose the tab “Console” and send us a screenshot.

You found the workaround though. You always can use the toolbar button or the keyboard shortcut.

That’s a different issue than what’s discussed in this thread.

What you see is the expected behaviour. You only can access those links if you open them from within Google docs. That ensures that only those people who have access to the Google Docs can change the citation data. Actually there have been quite a few discussions about this and we added this check to avoid that users accidentally publish PDFs without being aware of these links.

If you want your collaborators to have access to the reference data, you can share the original Google Doc with them.

Looks like …something?? is 404-ing, but I’m not sure that that’s actually the root issue.

actually, that’s the same behavior I’m seeing. I never tried the Ctl-Alt-P before, but this workaround works. BTW, I’m getting this non-working error on one of my three computers now. All running Windows, but different versions - not sure if that makes a difference. the nonworking PC is running Win 7 pro, service pack 1, circa 2009

Hello @stefan I had to share my draft to my colleague. I downloaded the google doc to word and when I opened the word file, the citations showed correctly but when I clicked on the citations this is what I got.

Kindly let me know what has to be done.