Provide support for OpenURL resolver

My university has recently deprecated EZProxy as part of moving towards SSO across all systems. This is preventing me from being able to import restricted files into Paperpile.

Instead they are providing an OpenURL resolver: https://library.unimelb.edu.au/search-tools/online-access/connect-to-our-systems. This does not work if pasted into Paperpile at the moment.

This is supported by Endnote and other reference managers: https://welch.jhmi.edu/get-help/what-openurl-and-authentication-url-endnote

2 Likes

We would need some help to fully understand the OpenURL workflow and how SSO comes into place there.

Let’s have a look at e.g. this paywalled Nature article: https://www.nature.com/articles/418244a

Feeding the bibliographic information into the OpenURL resolver gives this page: http://unimelb.hosted.exlibrisgroup.com/sfxlcl41?sid=google&auinit=GJ&aulast=Hannon&atitle=RNA+interference&id=doi:10.1038/418244a&title=Nature&volume=418&issue=6894&date=2002&spage=244&issn=0028-0836

Where the user can select different sources to go the full text.

There is also Nature listed. What exactly happens when you click on Nature? Are you taken directly to the Nature website or is there some login? Can you then access the PDF file on Nature?

If I click the link in Nature (https://www.nature.com/articles/418244a) I am taken to the Open Athens SSO page (https://sso.unimelb.edu.au/)

Once authenticated there is a token redirect back to the article page and I can access the PDF for download.

NB: In Chrome I have a University of Melbourne plugin that automatically provides SSO redirect for sites that they have access to. If I do this in FireFox then I need to click the “Access through your institution” button in Nature to trigger the above process.

image

Thanks, that helps a great deal. When you Click Nature on the Findit @ UniMelb page, it goes to https://go.openathens.net/redirector/unimelb.edu.au?url=https://doi.org/10.1038/418244a?nosfx=y
and then to the SSO sign in page, and then finally to Nature.

What is the exact URL for Nature you finally end up with? Is it some proxified URL, or just plain nature.com?

Also if you visit the URL twice, do you need to sign in again, or does it directly forward to the nature page?

This is the full URL sequence looking at the browser history (SAML requests redacted):

  1. Enter this in browser
    https:// go . openathens . net/redirector/unimelb.edu.au?url=https://doi.org/10.1038/418244a?nosfx=y

  2. Redirects to
    https:// sso . unimelb . edu . au/login/login.htm?fromURI=%2Fapp%2Funiversityofmelbourne_openathens_1%2Fexk4hneffrVDsz6Z03l6%2Fsso%2Fsaml%3FSAMLRequest%3D*****%253D%26RelayState%3D%252Fsaml%252F2%252Fsso%252Funimelb.edu.au%252Fo%252F71685714%252Fc%252Foafed%253FSAMLRequest%253D*********%2526RelayState%253Dhttps%25253A%25252F%25252Fwww.nature.com%25252Farticles%25252F418244a

  3. Redirects to
    https:// sso . unimelb . edu . au/signin/refresh-auth-state/*****

  4. Redirects to
    https:// sso . unimelb . edu . au/

  5. Enter authentication details

  6. Redirects to
    https:// sso . unimelb . edu . au/login/step-up/redirect?stateToken=*****

  7. Redirects to
    https:// login . openathens . net/saml/2/sso/unimelb.edu.au/o/71685714/c/oafed?SAMLRequest=*****&RelayState=https%3A%2F%2Fwww.nature.com%2Farticles%2F418244a

  8. Redirects to
    https:// www . nature . com/articles/418244a

Edit: had to remove links due to new user limits on links in forum.

If I visit this link a 2nd time once already authenticated then I end up at the Nature article directly:
https:// www . nature . com/articles/418244a

1 Like

Just my 2 cents, but OpenURL lookups are essential for me since they allow me to see whether a resource is available, either physically or electronically, through my university’s resources. If the resource is not available, I can automatically open our Interlibrary Loan page with much of the information needed for a request already filled in.

2 Likes

Thanks James - in a similar situation and also require OpenURL in order to access articles - any updates appreciated otherwise I am back to the dreaded Endnote.

1 Like

I am in the same boat. Plus, I am unable to change the URL in the iOS apps. They seem to be baked in, with no option for a custom URL.

1 Like

If it helps any further, our OpenURL resolver is here:
https://unimelb.hosted.exlibrisgroup.com/sfxlcl41

It would be great to know if this can be on the roadmap!

Cheers

Danny

Please implement this! My library also uses this and paperpile is fairly useless in comparison with competing products without this. @andreas @stefan

In fact, it’s very easy to implement.
The openurl resolver simply redirects the (logged in) user to where the file can actually be accessed. It’s a standardised system, and all you really need to process most requests is (for my case):
openurl resolver: http://ul2nb3kn6e.search.serialssolutions.com
university login (already in paperpile): http://proxy1-bib.sdu.dk:2048/login?url=
doi of file requested: 10.1177/10398562211014212
which forms a link (simplified for you using only doi. this link doesn’t require login to access): 360 Link

doi is simply url encoded, as you can see. All you need to use a openurl resolver is to append ?rft_id=info:doi%2F{url encoded doi} to the resolver url

from this page I was redirected to, I arrive at a website where I have to manually click this link: http://ul2nb3kn6e.search.serialssolutions.com.proxy1-bib.sdu.dk:2048/log?L=UL2NB3KN6E&D=J8X&J=AUSTPSYBU&P=Link&PT=EZProxy&A=Complex+PTSD+and+personality+disorder+in+ICD-11%3A+when+to+assign+one+or+two+diagnoses%3F&H=68cba95a70&U=http%3A%2F%2Fproxy1-bib.sdu.dk%3A2048%2Flogin%3Furl%3Dhttp%3A%2F%2Fjournals.sagepub.com%2Fdoi%2F10.1177%2F10398562211014212

and the link directs me to https://journals-sagepub-com.proxy1-bib.sdu.dk/doi/10.1177/10398562211014212

Where I can download the pdf at https://journals-sagepub-com.proxy1-bib.sdu.dk/doi/pdf/10.1177/10398562211014212

There exists an openurl 0.1 and a 1.0 standard, for the 0.1 standard you use ?id=doi:{url encoded doi} instead, but you cannot use both ?id=doi: and ?rft_id=info:doi.

Please implement this ASAP! And maybe give me a permanent free paperpile account in return for this service :smile:

Further reading available here: OpenURL notes - Helpful

Here you can find important up to date information about the OpenURL protocol. https://groups.niso.org/apps/group_public/download.php/14833/z39_88_2004_r2010.pdf

you’re apparently supposed to start with this parameter according to the docs (it communicates that it’s a 1.0 type request), but at my university and some other I tested, it seems to work fine without: ?ctx_ver=Z39.88-2004

2 Likes

Any news on whether this is possible? At the moment I can’t really use paperpile or recommend it to students so am considering pulling the plug. I don’t feel that this is a marginal case so hope we can get an update many thanks!

We have not been able to consider solutions for this but expect to prioritize the matter (and other proxy connection methods like OpenAthens) by the end of this year. Our current focus is to push the updates on the pipeline; original plans have suffered delays but we’re working hard to catch up. Sorry I don’t have a workaround to offer in the meantime.

This has completely killed Paperpile’s usability for me and sent me over to Zotero. Maybe one day I’ll be back, but this is a non-negotiable.

Welcome @Christopher_McMaster to the forum, and we are sorry for the inconvenience. The matter continues to be on our radar, but our dev team cannot work on resolving this issue until we have updated the web app (see @vicente’s post above). I have added your +1 to our internal tracker.

OpenAthens is not working for me :frowning: This, combined with slow development on numerous other fronts is making me very concerned how long I will remain a user of paperpile (I’ve been a user for 8 years!).

@lalarabbit (and everybody), following some updates we’ve had other users successfully configure access to OpenAthens (manually via library Settings > Proxy Access) with a link resolver looking like:

https://go.openathens.net/redirector/qut.edu.au?url=$@

You would need to replace the qut.edu.au bit with your own institution’s URL (or something like that). The most important thing is making sure to include ?url=$@ or /login?url=$@ at the end of the link. Anybody who’s able to try this with their institutional login, please let us know if it works.

This doesn’t work for Monash University. I was able to log in but testing the proxy was not successful.

@lalarabbit could you share the link you’re using so we can have a look?

This is the link: https://go.openathens.net/redirector/www.monash.edu?url=$@